summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 13:26:28 +0000
committerGrey Christoforo2019-02-09 13:26:28 +0000
commit2f32457ed5c1f734bf1817d6b3407d5bcdc4aaae (patch)
tree18e85458ba3d465add1fc8c5d70488de08ec01e8
parentbe3320a8127c864e76ed57916d53f54f9571635d (diff)
downloadaur-2f32457ed5c1f734bf1817d6b3407d5bcdc4aaae.tar.gz
version bump
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfb4c44b0e5f..09ea96f09df1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,12 @@
pkgbase = r-withr
- pkgdesc = Run Code With Temporarily Modified Global State
+ pkgdesc = Run Code 'With' Temporarily Modified Global State
pkgver = 2.1.2
pkgrel = 1
- url = https://cran.r-project.org/package=withr
- arch = any
- license = GPL
+ url = http://cran.r-project.org/web/packages/withr/index.html
+ arch = x86_64
+ license = GPL3
depends = r
- optdepends = r-testthat
- optdepends = r-covr
- optdepends = r-dbi
- optdepends = r-rsqlite
- optdepends = r-knitr
- optdepends = r-rmarkdown
- source = https://cran.r-project.org/src/contrib/withr_2.1.2.tar.gz
+ source = http://cran.r-project.org/src/contrib/withr_2.1.2.tar.gz
md5sums = 85e8574fb0a6832c4f275531be6371d6
pkgname = r-withr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index ae1a92033b83..07bc590ec514 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,19 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=withr
-_cranver=2.1.2
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-withr
-pkgver=${_cranver//[:-]/.}
+_cran_name=withr
+pkgver=2.1.2
pkgrel=1
-pkgdesc="Run Code With Temporarily Modified Global State"
-arch=('any')
-url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL')
-depends=('r' )
-
-optdepends=('r-testthat' 'r-covr' 'r-dbi' 'r-rsqlite' 'r-knitr' 'r-rmarkdown')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+pkgdesc="Run Code 'With' Temporarily Modified Global State"
+arch=('x86_64')
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
md5sums=('85e8574fb0a6832c4f275531be6371d6')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
-}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}