summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-06 18:03:00 +0000
committerBioArchLinuxBot2024-04-06 18:03:00 +0000
commit9babdd16f524db41043e455086bb4fe1c042b353 (patch)
tree58f0c09658399d6f5d5741718146e978c610a9e2
parent51ec4e5463bdc2fad045a5572cba595dd7f52776 (diff)
downloadaur-9babdd16f524db41043e455086bb4fe1c042b353.tar.gz
[lilac] updated to 1.60.0-2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61b7dc4a1fa7..648902e26922 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = r-xmapbridge
pkgdesc = Export plotting files to the xmapBridge for visualisation in X:Map
pkgver = 1.60.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/xmapbridge
arch = any
- license = LGPL
+ license = LGPL-3.0-only
depends = r
optdepends = r-rcolorbrewer
optdepends = r-runit
source = https://bioconductor.org/packages/release/bioc/src/contrib/xmapbridge_1.60.0.tar.gz
- sha256sums = 29347911d56347ef944cefac2a1c89f8dd3ced80bb8d31efb3b48b5011147e5d
+ md5sums = 8b07bc6daa0d9dad8943ef442076eb5e
+ b2sums = c313d64acb69bc52718885733d4f681cea82558679ba85e560d9140cc7a2965582d09fc20b458fecac3014d7ea8efcfb313696630c557c1d792fa7adabb642ec
pkgname = r-xmapbridge
diff --git a/PKGBUILD b/PKGBUILD
index 6203f04dccc2..a60b2f929326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=xmapbridge
_pkgver=1.60.0
pkgname=r-${_pkgname,,}
-pkgver=1.60.0
-pkgrel=1
-pkgdesc='Export plotting files to the xmapBridge for visualisation in X:Map'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('LGPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Export plotting files to the xmapBridge for visualisation in X:Map"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('LGPL-3.0-only')
depends=(
r
)
@@ -17,14 +17,15 @@ optdepends=(
r-runit
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('29347911d56347ef944cefac2a1c89f8dd3ced80bb8d31efb3b48b5011147e5d')
+md5sums=('8b07bc6daa0d9dad8943ef442076eb5e')
+b2sums=('c313d64acb69bc52718885733d4f681cea82558679ba85e560d9140cc7a2965582d09fc20b458fecac3014d7ea8efcfb313696630c557c1d792fa7adabb642ec')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: