summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2021-09-24 18:27:51 +0200
committerHyacinthe Cartiaux2021-09-24 18:27:51 +0200
commit2d4be7c262a0451a4b5c49a956a64bd984b78c11 (patch)
treed347a9e98f23f7edb58a60d0d391d401a8df450b
parent23795643692887dd62a6a55ff1006827e766d6b1 (diff)
downloadaur-2d4be7c262a0451a4b5c49a956a64bd984b78c11.tar.gz
Update to 0.12.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD37
2 files changed, 27 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7495ed292299..271061bb0af5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = r-xts
- pkgdesc = eXtensible Time Series
- pkgver = 0.11.1
+ pkgdesc = Provide for uniform handling of R's different time-based data classes by extending zoo, maximizing native format information preservation and allowing for user level customization and extension, while simplifying cross-class interoperability.
+ pkgver = 0.12.1
pkgrel = 1
url = https://cran.r-project.org/package=xts
- arch = x86_64
+ arch = any
license = GPL
- depends = r
depends = r-zoo>=1.7.12
optdepends = r-timeseries
optdepends = r-timedate
@@ -14,8 +13,7 @@ pkgbase = r-xts
optdepends = r-fts
optdepends = r-tis
optdepends = r-runit
- source = https://cran.r-project.org/src/contrib/xts_0.11-1.tar.gz
- md5sums = 949819b03bafd389cf7ed6e3ae59fec6
+ source = https://cran.r-project.org/src/contrib/xts_0.12.1.tar.gz
+ sha256sums = d680584af946fc30be0b2046e838cff7b3a65e00df1eadba325ca5e96f3dca2c
pkgname = r-xts
-
diff --git a/PKGBUILD b/PKGBUILD
index 76f792c965f9..d1cae6545471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranver=0.11-1
-pkgname=r-xts
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: Alex Branham <branham@utexas.edu>
+_cranname=xts
+_cranver=0.12.1
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='eXtensible Time Series'
-arch=('x86_64')
-url='https://cran.r-project.org/package=xts'
-license=('GPL')
-depends=('r' 'r-zoo>=1.7.12')
-optdepends=('r-timeseries' 'r-timedate' 'r-tseries' 'r-chron' 'r-fts' 'r-tis' 'r-runit')
-source=("https://cran.r-project.org/src/contrib/xts_"$_cranver".tar.gz")
-md5sums=('949819b03bafd389cf7ed6e3ae59fec6')
+pkgdesc="Provide for uniform handling of R's different time-based data classes by extending zoo, maximizing native format information preservation and allowing for user level customization and extension, while simplifying cross-class interoperability."
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL)
+depends=('r-zoo>=1.7.12')
+optdepends=(r-timeseries r-timedate r-tseries r-chron r-fts r-tis r-runit)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('d680584af946fc30be0b2046e838cff7b3a65e00df1eadba325ca5e96f3dca2c')
-build(){
- R CMD INSTALL xts_"$_cranver".tar.gz -l "$srcdir"
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership xts "$pkgdir"/usr/lib/R/library
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}