summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 17:05:44 -0500
committerAlex Branham2018-05-31 17:05:44 -0500
commita203200a29945841fd03621ccb9851cada345a56 (patch)
tree0550a0a29c6f73f23a24bb42800cf07a80927259
downloadaur-a203200a29945841fd03621ccb9851cada345a56.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dc40333e4a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-xts
+ pkgdesc = eXtensible Time Series
+ pkgver = 0.10.2
+ pkgrel = 1
+ url = https://cran.r-project.org/package=xts
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-zoo
+ depends = r-zoo
+ optdepends = r-timeseries
+ optdepends = r-timedate
+ optdepends = r-tseries
+ optdepends = r-chron
+ optdepends = r-fts
+ optdepends = r-tis
+ source = https://cran.r-project.org/src/contrib/xts_0.10-2.tar.gz
+ md5sums = c83c320e1699d060862214b70df92419
+
+pkgname = r-xts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efabab225bf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=xts
+_cranver=0.10-2
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-xts
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="eXtensible Time Series"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL')
+depends=('r' 'r-zoo' 'r-zoo')
+
+optdepends=('r-timeseries' 'r-timedate' 'r-tseries' 'r-chron' 'r-fts' 'r-tis')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('c83c320e1699d060862214b70df92419')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+