summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-07-17 09:52:23 -0500
committerAlex Branham2018-07-17 09:52:23 -0500
commit14979d6bd85e697f6dc01a41371a85663e67f323 (patch)
treed465fb9150c4956e75ebf6a598f6c6ad15a3eef6
parent76d9d14a7b53cda15a702562075bf8801bac7bb4 (diff)
downloadaur-14979d6bd85e697f6dc01a41371a85663e67f323.tar.gz
Upkg 1.8.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c5dda61a0f8..1b01ea3b4545 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-zoo
pkgdesc = S3 Infrastructure for Regular and Irregular Time Series (Zs Ordered Observations)
- pkgver = 1.8.2
+ pkgver = 1.8.3
pkgrel = 1
url = https://cran.r-project.org/package=zoo
arch = x86_64
@@ -19,8 +19,8 @@ pkgbase = r-zoo
optdepends = r-tis
optdepends = r-tseries
optdepends = r-xts
- source = https://cran.r-project.org/src/contrib/zoo_1.8-2.tar.gz
- md5sums = ca22a37a4b1a32ef9beeead47b2751f4
+ source = https://cran.r-project.org/src/contrib/zoo_1.8-3.tar.gz
+ md5sums = ea6fdac42e5109700dd502e667407e0a
pkgname = r-zoo
diff --git a/PKGBUILD b/PKGBUILD
index 2d02a0189151..52af06686e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=zoo
-_cranver=1.8-2
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+_cranver=1.8-3
pkgname=r-zoo
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="S3 Infrastructure for Regular and Irregular Time Series (Zs Ordered Observations)"
+pkgdesc='S3 Infrastructure for Regular and Irregular Time Series (Zs Ordered Observations)'
arch=('x86_64')
-url="https://cran.r-project.org/package=${_cranname}"
+url='https://cran.r-project.org/package=zoo'
license=('GPL')
depends=('r' )
-
optdepends=('r-coda' 'r-chron' 'r-daag' 'r-fts' 'r-ggplot2' 'r-mondate' 'r-scales' 'r-strucchange' 'r-timedate' 'r-timeseries' 'r-tis' 'r-tseries' 'r-xts')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('ca22a37a4b1a32ef9beeead47b2751f4')
+source=("https://cran.r-project.org/src/contrib/zoo_"$_cranver".tar.gz")
+md5sums=('ea6fdac42e5109700dd502e667407e0a')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL zoo_"$_cranver".tar.gz -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -d "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership zoo "$pkgdir"/usr/lib/R/library
}