summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2022-04-16 14:21:30 +0300
committerPekka Ristola2022-04-16 14:21:30 +0300
commit74c32c6b146390c369cb4f18c713f24014351e0d (patch)
treeb706927e3c12fdb15b3d6469df80f557cd07f60a
parentc4ea22ddd0d81c6be9154cc81b991e328af86175 (diff)
downloadaur-74c32c6b146390c369cb4f18c713f24014351e0d.tar.gz
Update to 1.8.10
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 34 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cac22803a47..f64beeedc3fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = r-zoo
pkgdesc = S3 Infrastructure for Regular and Irregular Time Series (Z's Ordered Observations)
- pkgver = 1.8.9
+ pkgver = 1.8.10
pkgrel = 1
url = https://cran.r-project.org/package=zoo
arch = i686
arch = x86_64
- license = GPL2
- license = GPL3
- depends = r>=3.1.0
+ license = GPL
+ depends = r
optdepends = r-aer
optdepends = r-coda
optdepends = r-chron
@@ -22,7 +21,7 @@ pkgbase = r-zoo
optdepends = r-tis
optdepends = r-tseries
optdepends = r-xts
- source = https://cran.r-project.org/src/contrib/zoo_1.8-9.tar.gz
- sha256sums = b7be259067a8b9d4a8f5d387e0946a5ba1eb43474baa67ccf4f8bf4b15f772a3
+ source = https://cran.r-project.org/src/contrib/zoo_1.8-10.tar.gz
+ sha256sums = c9a282d8004c22651c4fa1d657d3cad946c5ec55c4dc068569d860ee9b31ed47
pkgname = r-zoo
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index d12bf0adf1f9..fd076914177d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,42 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_cranname=zoo
-_cranver=1.8-9
+_cranver=1.8-10
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="S3 Infrastructure for Regular and Irregular Time Series (Z's Ordered Observations)"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-depends=('r>=3.1.0')
-optdepends=(r-aer r-coda r-chron r-fts r-ggplot2 r-mondate r-scales r-stinepack r-strucchange r-timedate r-timeseries r-tis r-tseries r-xts)
+license=(GPL)
+depends=(r)
+optdepends=(
+ r-aer
+ r-coda
+ r-chron
+ r-fts
+ r-ggplot2
+ r-mondate
+ r-scales
+ r-stinepack
+ r-strucchange
+ r-timedate
+ r-timeseries
+ r-tis
+ r-tseries
+ r-xts
+)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('b7be259067a8b9d4a8f5d387e0946a5ba1eb43474baa67ccf4f8bf4b15f772a3')
+sha256sums=('c9a282d8004c22651c4fa1d657d3cad946c5ec55c4dc068569d860ee9b31ed47')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
}