summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2019-04-11 17:00:09 +0200
committerJonas Heinrich2019-04-11 17:00:09 +0200
commitc0e4f7417f8dbf2952c168bba60cbcd168811e28 (patch)
treeaf49a5ef346bc22d94245db53043670b299b71a9
downloadaur-c0e4f7417f8dbf2952c168bba60cbcd168811e28.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7abdcf181fc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Apr 11 14:59:59 UTC 2019
+pkgbase = r128gain-git
+ pkgdesc = Fast audio loudness (ReplayGain / R128) scanner & tagger
+ pkgver = 0.8.0.r2.g6b4de54
+ pkgrel = 1
+ url = https://github.com/desbma/r128gain-git
+ arch = any
+ license = LGPL
+ depends = python
+ depends = python-setuptools
+ depends = python-mutagen
+ depends = python-crcmod
+ depends = ffmpeg
+ source = git+https://github.com/desbma/r128gain.git
+ sha512sums = SKIP
+
+pkgname = r128gain-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..306dfd16a52a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: desbma
+
+pkgname=r128gain-git
+_pkgname=r128gain
+pkgver=0.8.0.r2.g6b4de54
+pkgrel=1
+pkgdesc='Fast audio loudness (ReplayGain / R128) scanner & tagger'
+arch=('any')
+url="https://github.com/desbma/${pkgname}"
+license=('LGPL')
+depends=('python' 'python-setuptools' 'python-mutagen' 'python-crcmod' 'ffmpeg')
+source=("git+https://github.com/desbma/r128gain.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "r128gain"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}"
+}