summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevninja2016-09-27 20:29:53 -0400
committerdevninja2016-09-27 20:29:53 -0400
commitb90de921d4972e3e69c34f4e63d4aaab894540aa (patch)
tree7929596f9f9afc566dd2904c8e6a0fa0ca545cbd
parente04cedf0508c193eeee7535272da9b133a54ca78 (diff)
downloadaur-b90de921d4972e3e69c34f4e63d4aaab894540aa.tar.gz
updated from mainstream
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--linux-4.7.patch34
-rw-r--r--r8168.install2
4 files changed, 51 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78356ac36d41..9f65b6418e30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jul 25 18:27:58 UTC 2016
+# Wed Sep 28 00:29:43 UTC 2016
pkgbase = r8168-aufs
pkgdesc = A kernel module for Realtek 8168 network cards
pkgver = 8.042
- pkgrel = 2
+ pkgrel = 4
url = http://www.realtek.com.tw
install = r8168.install
arch = i686
@@ -14,10 +14,12 @@ pkgbase = r8168-aufs
depends = linux-aufs_friendly
source = https://github.com/mtorromeo/r8168/archive/8.042/r8168-8.042.tar.gz
source = linux-4.5.patch
+ source = linux-4.7.patch
sha256sums = 9dd8ae22115bcbef98c15b0b1e2160300cce3129ef7e0485d7e577188ba3fcc2
sha256sums = e05a4bccf28beecc97db246064a5fe80d1303476b76086bd262c9c8db82b2e6e
+ sha256sums = bbdc817278b17a1803c74228eaccbddb347ae92424a9a6cc92a68946f5392969
pkgname = r8168-aufs
- depends = linux-aufs_friendly>=
- depends = linux-aufs_friendly<.1
+ depends = linux>=
+ depends = linux<.1
diff --git a/PKGBUILD b/PKGBUILD
index 53292ed1cedb..c35fb5542592 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 178168 2016-06-08 05:41:00Z tpowa $
+# $Id: PKGBUILD 187549 2016-08-25 20:13:53Z tpowa $
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
# Contributor: Bob Fanger < bfanger(at)gmail >
# Contributor: Filip <fila pruda com>, Det < nimetonmaili(at)gmail >
@@ -6,7 +6,7 @@
pkgname=r8168-aufs
_pkgname=r8168
pkgver=8.042
-pkgrel=2
+pkgrel=4
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
@@ -15,17 +15,20 @@ depends=('glibc' 'linux-aufs_friendly')
makedepends=('linux-aufs_friendly-headers')
install=$_pkgname.install
source=(https://github.com/mtorromeo/r8168/archive/$pkgver/$_pkgname-$pkgver.tar.gz
- linux-4.5.patch)
+ linux-4.5.patch
+ linux-4.7.patch)
sha256sums=('9dd8ae22115bcbef98c15b0b1e2160300cce3129ef7e0485d7e577188ba3fcc2'
- 'e05a4bccf28beecc97db246064a5fe80d1303476b76086bd262c9c8db82b2e6e')
+ 'e05a4bccf28beecc97db246064a5fe80d1303476b76086bd262c9c8db82b2e6e'
+ 'bbdc817278b17a1803c74228eaccbddb347ae92424a9a6cc92a68946f5392969')
prepare() {
cd "$_pkgname-$pkgver"
patch -p1 -i ../linux-4.5.patch
+ patch -p1 -i ../linux-4.7.patch
}
build() {
- _kernver=$(pacman -Q linux-aufs_friendly | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
+ _kernver=$(pacman -Q linux | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-aufs_friendly/version)
cd "$_pkgname-$pkgver"
@@ -39,8 +42,8 @@ build() {
}
package() {
- _kernver=$(pacman -Q linux-aufs_friendly | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
- depends=("linux-aufs_friendly>=$_kernver" "linux-aufs_friendly<${_kernver/.*}.$(expr ${_kernver/*.} + 1)")
+ _kernver=$(pacman -Q linux | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
+ depends=("linux>=$_kernver" "linux<${_kernver/.*}.$(expr ${_kernver/*.} + 1)")
KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-aufs_friendly/version)
msg "Kernel = $KERNEL_VERSION"
diff --git a/linux-4.7.patch b/linux-4.7.patch
new file mode 100644
index 000000000000..6ef62d02d2ed
--- /dev/null
+++ b/linux-4.7.patch
@@ -0,0 +1,34 @@
+--- r8168-8.042.00/src/r8168_n.c.orig 2016-08-01 21:20:42.000000000 +0200
++++ r8168-8.042.00/src/r8168_n.c 2016-08-01 21:32:49.488072441 +0200
+@@ -22800,7 +22800,9 @@
+ dev->hw_features &= ~NETIF_F_IPV6_CSUM;
+ netif_set_gso_max_size(dev, LSO_32K);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+ dev->gso_min_segs = NIC_MIN_PHYS_BUF_COUNT;
++#endif
+ dev->gso_max_segs = NIC_MAX_PHYS_BUF_COUNT_LSO_64K;
+ #endif
+ } else {
+@@ -22808,7 +22810,9 @@
+ dev->features |= NETIF_F_IPV6_CSUM | NETIF_F_TSO6;
+ netif_set_gso_max_size(dev, LSO_64K);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+ dev->gso_min_segs = NIC_MIN_PHYS_BUF_COUNT;
++#endif
+ dev->gso_max_segs = NIC_MAX_PHYS_BUF_COUNT_LSO2;
+ #endif
+ }
+@@ -24970,7 +24974,11 @@
+ wmb();
+ txd->opts1 = cpu_to_le32(opts1);
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+ dev->trans_start = jiffies;
++#else
++ netif_trans_update(dev);
++#endif
+
+ tp->cur_tx += frags + 1;
+
diff --git a/r8168.install b/r8168.install
index e7eedba1892a..12b9919b0a47 100644
--- a/r8168.install
+++ b/r8168.install
@@ -1,5 +1,5 @@
rebuild_module_dependencies() {
- EXTRAMODULES='extramodules-4.6-aufs_friendly'
+ EXTRAMODULES='extramodules-4.7-aufs_friendly'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}