summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorenihcam2018-05-18 19:28:23 +0800
committerenihcam2018-05-18 19:28:23 +0800
commit5be501ea5a4ef7213929ad197c66009222824bcf (patch)
tree21c08f7e64d5baef99af6afbbb29c5237b4e299f
parent36a65c415cc86a1a981633f53c87492b856f450e (diff)
downloadaur-5be501ea5a4ef7213929ad197c66009222824bcf.tar.gz
Fixed version typo
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e76cd135933b..f48729740628 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r8168-ck
- pkgdesc = A kernel module for Realtek 8168 network cards
+ pkgdesc = A kernel module for Realtek 8168 network cards (linux-ck)
pkgver = 8.045.08
- pkgrel = 1
+ pkgrel = 2
url = http://www.realtek.com.tw
arch = x86_64
license = GPL
@@ -14,6 +14,6 @@ pkgbase = r8168-ck
sha256sums = 6434f0d1fcb08e3605a17859d3b8946c65bcf14737e223315b6468b3394c5cd7
pkgname = r8168-ck
- depends = linux-ck>=
- depends = linux-ck<.1
+ depends = linux-ck>=4.16
+ depends = linux-ck<4.17
diff --git a/PKGBUILD b/PKGBUILD
index 740aa6320bed..d76c7a4ccd05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# $Id$
# Maintainer: Enihcam <gmail: nanericwang>
-pkgname=r8168-ck
_pkgname=r8168
+_kernver=$(pacman -Q linux-ck | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
+pkgname=r8168-ck
pkgver=8.045.08
-pkgrel=1
-pkgdesc="A kernel module for Realtek 8168 network cards"
+pkgrel=2
+pkgdesc="A kernel module for Realtek 8168 network cards (linux-ck)"
url="http://www.realtek.com.tw"
license=("GPL")
arch=('x86_64')
@@ -22,7 +23,6 @@ prepare() {
}
build() {
- _kernver=$(pacman -Q linux-ck | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-ck/version)
msg2 "Kernel = $KERNEL_VERSION"
@@ -36,7 +36,6 @@ build() {
}
package() {
- _kernver=$(pacman -Q linux-ck | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
depends=("linux-ck>=$_kernver" "linux-ck<${_kernver/.*}.$(expr ${_kernver/*.} + 1)")
cd "$_pkgname-$pkgver"