summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlois Nespor2017-02-14 13:12:41 +0100
committerAlois Nespor2017-02-14 13:12:41 +0100
commit2e3be082ae22dabca7492a1b4306dbb3605875d1 (patch)
tree5e81bc5d4f6277ef4dfbd526694897286d036fea
parent38bdd05a5e8eaabee7d040d1e6ec6105904d3c78 (diff)
downloadaur-2e3be082ae22dabca7492a1b4306dbb3605875d1.tar.gz
Cleaning the PKG
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--linux-4.5.patch13
3 files changed, 12 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8059145a94f9..c026aa63326f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
# Generated by mksrcinfo v8
-# Mon Feb 13 11:47:49 UTC 2017
+# Tue Feb 14 12:12:20 UTC 2017
pkgbase = r8168-dkms
pkgdesc = A kernel module for Realtek 8168 network cards
pkgver = 8.044.02
- pkgrel = 1
+ pkgrel = 2
url = http://www.realtek.com.tw
install = r8168-dkms.install
arch = i686
arch = x86_64
license = GPL
+ makedepends = linux-headers
depends = glibc
depends = dkms
- optdepends = linux-headers: Build the module for Arch kernel
- optdepends = linux-lts-headers: Build the module for LTS Arch kernel
- optdepends = linux-zen-headers: Build the module for ZEN Arch kernel
conflicts = r8168
source = r8168-8.044.02.tar.gz::http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0009-r8168-8.044.02.tar.bz2
- source = linux-4.5.patch
source = dkms.conf
sha256sums = ad3cd1becb35efab52ed11e0326c1108806c55c62fd2b5e1cf7eaa749fb75027
- sha256sums = 96f3367037a54fe699981a2d7a4b92754629bae7143b1241d787bf59d4a95ffa
sha256sums = 260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763
pkgname = r8168-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 85ccb53148f6..5b2547fc2638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.044.02
-pkgrel=1
+pkgrel=2
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
arch=('i686' 'x86_64')
depends=('glibc' 'dkms')
conflicts=("${_pkgbase}")
-optdepends=('linux-headers: Build the module for Arch kernel'
- 'linux-lts-headers: Build the module for LTS Arch kernel'
- 'linux-zen-headers: Build the module for ZEN Arch kernel')
-source=(r8168-$pkgver.tar.gz::http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0009-r8168-8.044.02.tar.bz2 #http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0009-r8168-8.044.02.tar.bz2
- 'linux-4.5.patch'
+makedepends=('linux-headers')
+source=(r8168-$pkgver.tar.gz::http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0009-r8168-8.044.02.tar.bz2
'dkms.conf')
install=r8168-dkms.install
-sha256sums=('ad3cd1becb35efab52ed11e0326c1108806c55c62fd2b5e1cf7eaa749fb75027'
- '96f3367037a54fe699981a2d7a4b92754629bae7143b1241d787bf59d4a95ffa'
- '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
-prepare() {
- cd "r8168-$pkgver"
- patch -p1 -i ../linux-4.5.patch
-}
+#prepare() {
+# cd "r8168-$pkgver"
+# patch -p1 -i ../name.patch
+#}
package() {
@@ -36,3 +30,5 @@ package() {
rm src/Makefile_linux24x
cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
}
+sha256sums=('ad3cd1becb35efab52ed11e0326c1108806c55c62fd2b5e1cf7eaa749fb75027'
+ '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
diff --git a/linux-4.5.patch b/linux-4.5.patch
deleted file mode 100644
index 2fd70bfd565c..000000000000
--- a/linux-4.5.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- r8168-8.042/src/r8168_n.c.orig 2016-08-22 14:22:48.694631079 +0800
-+++ r8168-8.042/src/r8168_n.c 2016-08-22 14:24:53.279449184 +0800
-@@ -4320,7 +4320,11 @@
- features &= ~NETIF_F_ALL_TSO;
- if (dev->mtu > ETH_DATA_LEN) {
- features &= ~NETIF_F_ALL_TSO;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4,5,0)
- features &= ~NETIF_F_ALL_CSUM;
-+#else
-+ features &= ~NETIF_F_CSUM_MASK;
-+#endif
- }
- spin_unlock_irqrestore(&tp->lock, flags);