summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-08-13 02:18:17 -0400
committerPatrick Northon2023-08-13 02:18:17 -0400
commit3f1ebeced0a46ca8017a65d3f32088afea23cbdf (patch)
tree49fc631fee8309e741373570d9dbaeb170c6e82f
parent0cdf3947f152211c0af5367984bfb5cff9287729 (diff)
downloadaur-3f1ebeced0a46ca8017a65d3f32088afea23cbdf.tar.gz
Add patch for kernel v6.4, correctly use version tag and remove useless install file.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
-rw-r--r--r8168-dkms-v6.4.patch12
-rw-r--r--r8168-dkms.install15
4 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fbb1c788588..b0768243f501 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = r8168-dkms
pkgdesc = A kernel module for Realtek 8168 network cards (DKMS version)
pkgver = 8.051.02
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mtorromeo/r8168
- install = r8168-dkms.install
arch = i686
arch = x86_64
license = GPL
@@ -12,11 +11,13 @@ pkgbase = r8168-dkms
depends = dkms
provides = r8168
conflicts = r8168
- source = r8168-dkms::git+https://github.com/mtorromeo/r8168.git
- source = r8168-dkms-6.1.patch::https://github.com/mtorromeo/r8168/pull/47.patch
+ source = r8168-dkms::git+https://github.com/mtorromeo/r8168.git#tag=8.051.02
+ source = r8168-dkms-v6.1.patch::https://github.com/mtorromeo/r8168/pull/47.patch
source = dkms.conf
+ source = r8168-dkms-v6.4.patch
sha256sums = SKIP
sha256sums = b7ef09e7496715b7576b7a3bff5a96e0e07c0bb02cd5bb5805415be20b883f60
sha256sums = d37b8acbd4fe06f81538581712a04751a96fc37bad3a4bd3ae8329f8744c49b3
+ sha256sums = 34c8aa59e83eda52f9923b6f32c45742b6f62491ba74b5a249aad2153621965e
pkgname = r8168-dkms
diff --git a/PKGBUILD b/PKGBUILD
index b890cd60832e..7c70f3251bc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.051.02
-pkgrel=2
+pkgrel=3
pkgdesc="A kernel module for Realtek 8168 network cards (DKMS version)"
url="https://github.com/mtorromeo/r8168"
license=("GPL")
@@ -17,17 +17,19 @@ depends=('glibc' 'dkms')
makedepends=('git')
conflicts=("${_pkgbase}")
provides=("${_pkgbase}")
-source=("r8168-dkms::git+https://github.com/mtorromeo/r8168.git"
- "${pkgname}-6.1.patch::https://github.com/mtorromeo/r8168/pull/47.patch"
- "dkms.conf")
+source=("r8168-dkms::git+https://github.com/mtorromeo/r8168.git#tag=${pkgver}"
+ "${pkgname}-v6.1.patch::https://github.com/mtorromeo/r8168/pull/47.patch"
+ 'dkms.conf'
+ "${pkgname}-v6.4.patch")
sha256sums=('SKIP'
'b7ef09e7496715b7576b7a3bff5a96e0e07c0bb02cd5bb5805415be20b883f60'
- 'd37b8acbd4fe06f81538581712a04751a96fc37bad3a4bd3ae8329f8744c49b3')
-install=r8168-dkms.install
+ 'd37b8acbd4fe06f81538581712a04751a96fc37bad3a4bd3ae8329f8744c49b3'
+ '34c8aa59e83eda52f9923b6f32c45742b6f62491ba74b5a249aad2153621965e')
prepare() {
cd "${pkgname}"
- patch -p1 -i "$srcdir/${pkgname}-6.1.patch"
+ patch -p1 -i "$srcdir/${pkgname}-v6.1.patch"
+ patch -p1 -i "$srcdir/${pkgname}-v6.4.patch"
}
package() {
diff --git a/r8168-dkms-v6.4.patch b/r8168-dkms-v6.4.patch
new file mode 100644
index 000000000000..207d5d6d33eb
--- /dev/null
+++ b/r8168-dkms-v6.4.patch
@@ -0,0 +1,12 @@
+--- a/src/r8168_n.c 2023-08-13 03:33:06.977422132 +0400
++++ b/src/r8168_n.c 2023-08-13 03:38:39.767005101 +0400
+@@ -81,6 +81,10 @@
+ #include <linux/mdio.h>
+ #endif
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6,4,0)
++#include <net/gso.h>
++#endif
++
+ #include <asm/io.h>
+ #include <asm/irq.h>
diff --git a/r8168-dkms.install b/r8168-dkms.install
deleted file mode 100644
index e8a5013baad8..000000000000
--- a/r8168-dkms.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- dkms add r8168/${1%-*}
-}
-
-pre_upgrade() {
- pre_remove "$2"
-}
-
-post_upgrade() {
- post_install "$1"
-}
-
-pre_remove() {
- [ -n "${1%-*}" ] && dkms remove r8168/${1%-*} --all &>/dev/null || true
-}