summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlois Nespor2017-05-20 18:22:43 +0200
committerAlois Nespor2017-05-20 18:22:43 +0200
commit47c2c6a366e2b5803c8310ec9ef821ed191912be (patch)
tree985fefff12604d183deab1fb66596a6c56b96faf
parent4fdaec5996810b6a57af677debb2c270dc5a449f (diff)
downloadaur-47c2c6a366e2b5803c8310ec9ef821ed191912be.tar.gz
Update and add patch for kernel 4.11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--linux-4.11.patch14
3 files changed, 27 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33f2494c167d..2e80db73b99f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Feb 14 12:25:58 UTC 2017
+# Sat May 20 16:22:39 UTC 2017
pkgbase = r8168-dkms
pkgdesc = A kernel module for Realtek 8168 network cards
pkgver = 8.044.02
- pkgrel = 2
+ pkgrel = 3
url = http://www.realtek.com.tw
install = r8168-dkms.install
arch = i686
@@ -17,8 +17,10 @@ pkgbase = r8168-dkms
conflicts = r8168
source = https://github.com/mtorromeo/r8168/archive/8.044.02/r8168-8.044.02.tar.gz
source = dkms.conf
+ source = linux-4.11.patch
sha256sums = aad7bccc4f625c35abe0455b2a6271e9938b76b46e11b24b4f138eb5c95db6d3
sha256sums = 260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763
+ sha256sums = 21857077bd5b26a08456f97f170b2772e8cadfb331577ddb2bcb680b31c5c0d3
pkgname = r8168-dkms
diff --git a/PKGBUILD b/PKGBUILD
index a32c3eaee26d..bb4effec4324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.044.02
-pkgrel=2
+pkgrel=3
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
@@ -12,13 +12,14 @@ optdepends=('linux-headers: Needed for build the module for Arch kernel'
'linux-lts-headers: Needed for build the module for LTS Arch kernel'
'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
source=(https://github.com/mtorromeo/r8168/archive/$pkgver/r8168-$pkgver.tar.gz
- 'dkms.conf')
+ 'dkms.conf'
+ linux-4.11.patch)
install=r8168-dkms.install
-#prepare() {
-# cd "r8168-$pkgver"
-# patch -p1 -i ../name.patch
-#}
+prepare() {
+ cd "r8168-$pkgver"
+ patch -p1 -i "$srcdir/linux-4.11.patch"
+}
package() {
@@ -33,4 +34,5 @@ package() {
cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
}
sha256sums=('aad7bccc4f625c35abe0455b2a6271e9938b76b46e11b24b4f138eb5c95db6d3'
- '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
+ '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763'
+ '21857077bd5b26a08456f97f170b2772e8cadfb331577ddb2bcb680b31c5c0d3')
diff --git a/linux-4.11.patch b/linux-4.11.patch
new file mode 100644
index 000000000000..5d8d451cdf87
--- /dev/null
+++ b/linux-4.11.patch
@@ -0,0 +1,14 @@
+diff --git a/src/r8168_n.c b/src/r8168_n.c
+index 3c5a7e7..e2026bb 100755
+--- a/src/r8168_n.c
++++ b/src/r8168_n.c
+@@ -25732,7 +25732,9 @@ process_pkt:
+ if (rtl8168_rx_vlan_skb(tp, desc, skb) < 0)
+ rtl8168_rx_skb(tp, skb);
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ dev->last_rx = jiffies;
++#endif
+ RTLDEV->stats.rx_bytes += pkt_size;
+ RTLDEV->stats.rx_packets++;
+ }