summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan Simon2020-04-08 12:21:57 +0200
committerJuan Simon2020-04-08 12:21:57 +0200
commit47da6ef7b5733633ec9859c15d2ad4d2467777a4 (patch)
treec41bcc2d295912c5ba9c383f81e5bb765393c1de
parent646169bbd4ba9021cf75d264f5c79637d6da9d08 (diff)
downloadaur-47da6ef7b5733633ec9859c15d2ad4d2467777a4.tar.gz
PKGBUILD corrections
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--r8168-dkms.install2
3 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10963b48df96..9453f32f39d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r8168-dkms
pkgdesc = A kernel module for Realtek 8168 network cards (DKMS version)
pkgver = 8.048.02
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/simonbcn/r8168-dkms
install = r8168-dkms.install
arch = i686
@@ -10,9 +10,6 @@ pkgbase = r8168-dkms
makedepends = git
depends = glibc
depends = dkms
- optdepends = linux-headers: Needed for build the module for Arch kernel
- optdepends = linux-lts-headers: Needed for build the module for LTS Arch kernel
- optdepends = linux-zen-headers: Needed for build the module for ZEN Arch kernel
conflicts = r8168-dkms
source = r8168-dkms::git+https://github.com/simonbcn/r8168-dkms.git
source = dkms.conf
diff --git a/PKGBUILD b/PKGBUILD
index b5b01a322758..4052718ce2b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.048.02
-pkgrel=2
+pkgrel=3
pkgdesc="A kernel module for Realtek 8168 network cards (DKMS version)"
url="https://github.com/simonbcn/r8168-dkms"
license=("GPL")
@@ -12,23 +12,20 @@ arch=('i686' 'x86_64')
depends=('glibc' 'dkms')
makedepends=('git')
conflicts=("${pkgname}")
-optdepends=('linux-headers: Needed for build the module for Arch kernel'
- 'linux-lts-headers: Needed for build the module for LTS Arch kernel'
- 'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
source=("r8168-dkms::git+https://github.com/simonbcn/r8168-dkms.git"
dkms.conf)
install=r8168-dkms.install
package() {
- install -Dm644 dkms.conf "${pkgdir}/usr/src/${pkgname}-${pkgver}/dkms.conf"
+ install -Dm644 dkms.conf "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
sed -e "s/@PKGNAME@/${_pkgbase}/g" \
- -e "s/@PKGVER@/${_pkgbase}/g" \
- -i "${pkgdir}/usr/src/${pkgname}-${pkgver}/dkms.conf"
+ -e "s/@PKGVER@/${pkgver}/g" \
+ -i "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
cd "${pkgname}"
rm src/Makefile_linux24x
- cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${pkgname}-${pkgver}/src"
+ cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
}
sha256sums=('SKIP'
'e33abcbc8fbe3129459ebc60be3b2f8ed55ddc53755f4956d6feb16c61c43250')
diff --git a/r8168-dkms.install b/r8168-dkms.install
index 41b01ecaf78c..70eaa49a9bf2 100644
--- a/r8168-dkms.install
+++ b/r8168-dkms.install
@@ -1,8 +1,6 @@
post_install() {
dkms add r8168/${1%-*}
cat << EOF
-==> To build and install your modules run: dkms install r8168/${1%-*}
-==> To do this automatically at startup run: systemctl enable dkms.service
==> The module r8168 conflicts with r8169. You can blacklist it with:
==> echo "blacklist r8169" > /etc/modprobe.d/r8169_blacklist.conf
EOF