summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaire Farron2016-04-30 18:05:08 +0100
committerClaire Farron2016-04-30 18:05:08 +0100
commit552c8e077b033e3811bd53e807f9d790b7fac93c (patch)
tree35874b21130e81ddea85282feb9426b88c35bbf6
parentc29ddd8ffeb0c496de8d7d8e30b9f19fd7f3aa58 (diff)
downloadaur-552c8e077b033e3811bd53e807f9d790b7fac93c.tar.gz
Branch Update to 8.041.00, including patch for kernel 4.5.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
-rw-r--r--linux-4.5.patch12
3 files changed, 37 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f37724d85ba5..3ce53bf315fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Sat Apr 30 17:05:03 UTC 2016
pkgbase = r8168-dkms
pkgdesc = A kernel module for Realtek 8168 network cards
- pkgver = 8.040.00
- pkgrel = 7
+ pkgver = 8.041.00
+ pkgrel = 2
url = http://www.realtek.com.tw
- install = r8168-dkms.install
arch = i686
arch = x86_64
license = GPL
@@ -12,9 +13,11 @@ pkgbase = r8168-dkms
optdepends = linux-headers: Build the module for Arch kernel
optdepends = linux-lts-headers: Build the module for LTS Arch kernel
conflicts = r8168
- source = https://github.com/mtorromeo/r8168/archive/8.040.00/r8168-8.040.00.tar.gz
+ source = https://github.com/mtorromeo/r8168/archive/8.041.00/r8168-8.041.00.tar.gz
+ source = linux-4.5.patch
source = dkms.conf
- sha256sums = 1f7aad3a066c152837e03e558ba720742e792d281c96c5412cff32d68875415b
+ sha256sums = d56f60e4157ccbf8f8717270b1acb391b0a959d9a96c2f0b4a91c683aa8b83a5
+ sha256sums = 6416bb61b72316a519d36dc5c3e50019b2b2f75a017ed6e49626ad57916ec60a
sha256sums = 260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763
pkgname = r8168-dkms
diff --git a/PKGBUILD b/PKGBUILD
index c5ce4345d12a..7beacd321b2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
-pkgver=8.040.00
-pkgrel=7
+pkgver=8.041.00
+pkgrel=2
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
@@ -10,18 +10,28 @@ depends=('glibc' 'dkms')
conflicts=("${_pkgbase}")
optdepends=('linux-headers: Build the module for Arch kernel'
'linux-lts-headers: Build the module for LTS Arch kernel')
-install=$pkgname.install
-source=(https://github.com/mtorromeo/r8168/archive/$pkgver/$_pkgbase-$pkgver.tar.gz dkms.conf)
-sha256sums=('1f7aad3a066c152837e03e558ba720742e792d281c96c5412cff32d68875415b' '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
+#install=$pkgname.install
+source=(https://github.com/mtorromeo/r8168/archive/$pkgver/r8168-$pkgver.tar.gz
+ 'linux-4.5.patch'
+ 'dkms.conf')
+sha256sums=('d56f60e4157ccbf8f8717270b1acb391b0a959d9a96c2f0b4a91c683aa8b83a5'
+ '6416bb61b72316a519d36dc5c3e50019b2b2f75a017ed6e49626ad57916ec60a'
+ '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
+
+prepare() {
+ cd "r8168-$pkgver"
+ patch -p1 -i ../linux-4.5.patch
+}
+
package() {
install -Dm644 dkms.conf "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
sed -e "s/@PKGNAME@/${_pkgbase}/g" \
- -e "s/@PKGVER@/${pkgver}/g" \
+ -e "s/@PKGVER@/${_pkgbase}/g" \
-i "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
- cd "$_pkgbase-$pkgver"
+ cd "${_pkgbase}-$pkgver"
rm src/Makefile_linux24x
cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
}
diff --git a/linux-4.5.patch b/linux-4.5.patch
new file mode 100644
index 000000000000..dbf3243d0406
--- /dev/null
+++ b/linux-4.5.patch
@@ -0,0 +1,12 @@
+diff --git a/src/r8168_n.c b/src/r8168_n.c
+index d197630..b47419d 100755
+--- a/src/r8168_n.c
++++ b/src/r8168_n.c
+@@ -4209,7 +4209,7 @@ static netdev_features_t rtl8168_fix_features(struct net_device *dev,
+ spin_lock_irqsave(&tp->lock, flags);
+ if (dev->mtu > ETH_DATA_LEN) {
+ features &= ~NETIF_F_ALL_TSO;
+- features &= ~NETIF_F_ALL_CSUM;
++ features &= ~NETIF_F_CSUM_MASK;
+ }
+ spin_unlock_irqrestore(&tp->lock, flags);