summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaire Farron2016-09-03 20:15:01 +0100
committerClaire Farron2016-09-03 20:15:01 +0100
commited631f1532be4a455576e93ffd78cc802769afc2 (patch)
treeabff9c60057703abb00564bb1278d115ef3b7aa8
parent826a3803b7caf537bd73fd2996e727580e4fa0b0 (diff)
downloadaur-ed631f1532be4a455576e93ffd78cc802769afc2.tar.gz
Updated for >linux-4.7 support.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--linux-4.5.patch15
-rw-r--r--linux-4.7.patch35
4 files changed, 53 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0a895cd7a05..80f976b21939 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 14 16:37:49 UTC 2016
+# Sat Sep 3 19:14:57 UTC 2016
pkgbase = r8168-dkms
pkgdesc = A kernel module for Realtek 8168 network cards
pkgver = 8.042
- pkgrel = 1
+ pkgrel = 3
url = http://www.realtek.com.tw
arch = i686
arch = x86_64
@@ -15,9 +15,11 @@ pkgbase = r8168-dkms
conflicts = r8168
source = https://github.com/mtorromeo/r8168/archive/8.042/r8168-8.042.tar.gz
source = linux-4.5.patch
+ source = linux-4.7.patch
source = dkms.conf
sha256sums = 9dd8ae22115bcbef98c15b0b1e2160300cce3129ef7e0485d7e577188ba3fcc2
- sha256sums = 6416bb61b72316a519d36dc5c3e50019b2b2f75a017ed6e49626ad57916ec60a
+ sha256sums = 96f3367037a54fe699981a2d7a4b92754629bae7143b1241d787bf59d4a95ffa
+ sha256sums = defdca26208590a9e1225d8dd51edea412f49420a99d9877c34600d5f88065a0
sha256sums = 260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763
pkgname = r8168-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 55e2efed8ebd..49207b7cb835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.042
-pkgrel=1
+pkgrel=3
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
@@ -13,14 +13,17 @@ optdepends=('linux-headers: Build the module for Arch kernel'
#install=$pkgname.install
source=(https://github.com/mtorromeo/r8168/archive/$pkgver/r8168-$pkgver.tar.gz
'linux-4.5.patch'
+ 'linux-4.7.patch'
'dkms.conf')
sha256sums=('9dd8ae22115bcbef98c15b0b1e2160300cce3129ef7e0485d7e577188ba3fcc2'
- '6416bb61b72316a519d36dc5c3e50019b2b2f75a017ed6e49626ad57916ec60a'
+ '96f3367037a54fe699981a2d7a4b92754629bae7143b1241d787bf59d4a95ffa'
+ 'defdca26208590a9e1225d8dd51edea412f49420a99d9877c34600d5f88065a0'
'260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
prepare() {
cd "r8168-$pkgver"
patch -p1 -i ../linux-4.5.patch
+ patch -p1 -i ../linux-4.7.patch
}
diff --git a/linux-4.5.patch b/linux-4.5.patch
index dbf3243d0406..2fd70bfd565c 100644
--- a/linux-4.5.patch
+++ b/linux-4.5.patch
@@ -1,12 +1,13 @@
-diff --git a/src/r8168_n.c b/src/r8168_n.c
-index d197630..b47419d 100755
---- a/src/r8168_n.c
-+++ b/src/r8168_n.c
-@@ -4209,7 +4209,7 @@ static netdev_features_t rtl8168_fix_features(struct net_device *dev,
- spin_lock_irqsave(&tp->lock, flags);
+--- r8168-8.042/src/r8168_n.c.orig 2016-08-22 14:22:48.694631079 +0800
++++ r8168-8.042/src/r8168_n.c 2016-08-22 14:24:53.279449184 +0800
+@@ -4320,7 +4320,11 @@
+ features &= ~NETIF_F_ALL_TSO;
if (dev->mtu > ETH_DATA_LEN) {
features &= ~NETIF_F_ALL_TSO;
-- features &= ~NETIF_F_ALL_CSUM;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,5,0)
+ features &= ~NETIF_F_ALL_CSUM;
++#else
+ features &= ~NETIF_F_CSUM_MASK;
++#endif
}
spin_unlock_irqrestore(&tp->lock, flags);
diff --git a/linux-4.7.patch b/linux-4.7.patch
new file mode 100644
index 000000000000..3004dc5cefb3
--- /dev/null
+++ b/linux-4.7.patch
@@ -0,0 +1,35 @@
+--- r8168-8.042.00/src/r8168_n.c.orig 2016-08-01 21:20:42.000000000 +0200
++++ r8168-8.042.00/src/r8168_n.c 2016-08-01 21:32:49.488072441 +0200
+@@ -22800,7 +22800,9 @@
+ dev->hw_features &= ~NETIF_F_IPV6_CSUM;
+ netif_set_gso_max_size(dev, LSO_32K);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+ dev->gso_min_segs = NIC_MIN_PHYS_BUF_COUNT;
++#endif
+ dev->gso_max_segs = NIC_MAX_PHYS_BUF_COUNT_LSO_64K;
+ #endif
+ } else {
+@@ -22808,7 +22810,9 @@
+ dev->features |= NETIF_F_IPV6_CSUM | NETIF_F_TSO6;
+ netif_set_gso_max_size(dev, LSO_64K);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+ dev->gso_min_segs = NIC_MIN_PHYS_BUF_COUNT;
++#endif
+ dev->gso_max_segs = NIC_MAX_PHYS_BUF_COUNT_LSO2;
+ #endif
+ }
+@@ -24970,7 +24974,11 @@
+ wmb();
+ txd->opts1 = cpu_to_le32(opts1);
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+ dev->trans_start = jiffies;
++#else
++ netif_trans_update(dev);
++#endif
+
+ tp->cur_tx += frags + 1;
+
+