summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2016-05-08 22:22:57 +0800
committerwangjiezhe2016-05-08 22:22:57 +0800
commit976c7550affa4e5ae1e9a86121a159389a19ac02 (patch)
treef6eabe7a790bf57f411262b0a435e96e71525db0
parentff603395a65e83e8456cda50f7beff68afea0a5b (diff)
downloadaur-976c7550affa4e5ae1e9a86121a159389a19ac02.tar.gz
r8168-pf 8.041.00-5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD40
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d63b553f4e44..aa5badb8b970 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Apr 20 14:20:12 UTC 2016
+# Sun May 8 14:22:53 UTC 2016
pkgbase = r8168-pf
pkgdesc = A kernel module for Realtek 8168 network cards(pf kernel)
pkgver = 8.041.00
- pkgrel = 4
+ pkgrel = 5
url = http://www.realtek.com.tw
install = r8168.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b07b40402b46..583c88d5181c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=r8168
pkgname=r8168-pf
pkgver=8.041.00
-pkgrel=4
+pkgrel=5
pkgdesc="A kernel module for Realtek 8168 network cards(pf kernel)"
url="http://www.realtek.com.tw"
license=("GPL")
@@ -20,33 +20,33 @@ sha256sums=('d56f60e4157ccbf8f8717270b1acb391b0a959d9a96c2f0b4a91c683aa8b83a5'
'e05a4bccf28beecc97db246064a5fe80d1303476b76086bd262c9c8db82b2e6e')
prepare() {
- cd "$_pkgname-$pkgver"
- patch -p1 -i ../linux-4.5.patch
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../linux-4.5.patch
}
build() {
- _kernver=$(pacman -Q linux-pf | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
- KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-pf/version)
+ _kernver=$(pacman -Q linux-pf | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
+ KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-pf/version)
- cd "$_pkgname-$pkgver"
+ cd "$_pkgname-$pkgver"
- # avoid using the Makefile directly -- it doesn't understand
- # any kernel but the current.
- make -C /usr/lib/modules/$KERNEL_VERSION/build \
- SUBDIRS="$srcdir/$_pkgname-$pkgver/src" \
- EXTRA_CFLAGS="-DCONFIG_R8168_NAPI -DCONFIG_R8168_VLAN" \
- modules
+ # avoid using the Makefile directly -- it doesn't understand
+ # any kernel but the current.
+ make -C /usr/lib/modules/$KERNEL_VERSION/build \
+ SUBDIRS="$srcdir/$_pkgname-$pkgver/src" \
+ EXTRA_CFLAGS="-DCONFIG_R8168_NAPI -DCONFIG_R8168_VLAN" \
+ modules
}
package() {
- _kernver=$(pacman -Q linux-pf | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
- depends=("linux-pf>=$_kernver" "linux-pf<${_kernver/.*}.$(expr ${_kernver/*.} + 1)")
- KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-pf/version)
- msg "Kernel = $KERNEL_VERSION"
+ _kernver=$(pacman -Q linux-pf | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
+ depends=("linux-pf>=$_kernver" "linux-pf<${_kernver/.*}.$(expr ${_kernver/*.} + 1)")
+ KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-pf/version)
+ msg "Kernel = $KERNEL_VERSION"
- cd "$_pkgname-$pkgver"
- install -Dm644 src/$_pkgname.ko "$pkgdir/usr/lib/modules/extramodules-$_kernver-pf/$_pkgname.ko"
- find "$pkgdir" -name '*.ko' -exec gzip -9 {} +
+ cd "$_pkgname-$pkgver"
+ install -Dm644 src/$_pkgname.ko "$pkgdir/usr/lib/modules/extramodules-$_kernver-pf/$_pkgname.ko"
+ find "$pkgdir" -name '*.ko' -exec gzip -9 {} +
- sed -i "s|extramodules-.*-pf|extramodules-$_kernver-pf|" "$startdir/$_pkgname.install"
+ sed -i "s|extramodules-.*-pf|extramodules-$_kernver-pf|" "$startdir/$_pkgname.install"
}