summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2017-02-15 18:28:41 +0800
committerwangjiezhe2017-02-15 18:28:41 +0800
commita291cf696bd7e71e37e25ea61bc5ed310c5dd4cc (patch)
tree0f7e16a7bb930356f062314787dad1386772c6be
parent74117c72dff7b3626fc2ac6dd5935b738300b039 (diff)
downloadaur-a291cf696bd7e71e37e25ea61bc5ed310c5dd4cc.tar.gz
r8168-pf 8.044.02-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--linux-4.5.patch13
3 files changed, 7 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 331f090b8898..94767c72d60f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jan 13 01:13:09 UTC 2017
+# Wed Feb 15 10:28:34 UTC 2017
pkgbase = r8168-pf
pkgdesc = A kernel module for Realtek 8168 network cards(pf kernel)
- pkgver = 8.043.02
+ pkgver = 8.044.02
pkgrel = 1
url = http://www.realtek.com.tw
install = r8168.install
@@ -13,10 +13,8 @@ pkgbase = r8168-pf
depends = glibc
depends = linux-pf>=4.9
depends = linux-pf<4.10
- source = r8168-8.043.02.tar.gz::https://github.com/mtorromeo/r8168/archive/8.043.02.tar.gz
- source = linux-4.5.patch
- sha256sums = ea22aa1dfda20615f5e114f982f7e61385f871f682eea0c154245760a439abc4
- sha256sums = e05a4bccf28beecc97db246064a5fe80d1303476b76086bd262c9c8db82b2e6e
+ source = r8168-8.044.02.tar.gz::https://github.com/mtorromeo/r8168/archive/8.044.02.tar.gz
+ sha256sums = aad7bccc4f625c35abe0455b2a6271e9938b76b46e11b24b4f138eb5c95db6d3
pkgname = r8168-pf
diff --git a/PKGBUILD b/PKGBUILD
index 9a2195f876d5..a30f141190af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=r8168
_kernver=$(pacman -Q linux-pf | sed -r 's#.* ([0-9]+\.[0-9]+).*#\1#')
pkgname=r8168-pf
-pkgver=8.043.02
+pkgver=8.044.02
pkgrel=1
pkgdesc="A kernel module for Realtek 8168 network cards(pf kernel)"
url="http://www.realtek.com.tw"
@@ -15,18 +15,11 @@ arch=('i686' 'x86_64')
depends=('glibc' "linux-pf>=$_kernver" "linux-pf<${_kernver/.*}.$(expr ${_kernver/*.} + 1)")
makedepends=('linux-pf-headers')
install=$_pkgname.install
-source=("$_pkgname-$pkgver.tar.gz"::"https://github.com/mtorromeo/r8168/archive/$pkgver.tar.gz"
- "linux-4.5.patch")
-sha256sums=('ea22aa1dfda20615f5e114f982f7e61385f871f682eea0c154245760a439abc4'
- 'e05a4bccf28beecc97db246064a5fe80d1303476b76086bd262c9c8db82b2e6e')
+source=("$_pkgname-$pkgver.tar.gz"::"https://github.com/mtorromeo/r8168/archive/$pkgver.tar.gz")
+sha256sums=('aad7bccc4f625c35abe0455b2a6271e9938b76b46e11b24b4f138eb5c95db6d3')
KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-$_kernver-pf/version)
-prepare() {
- cd "$_pkgname-$pkgver"
- patch -p1 -i ../linux-4.5.patch
-}
-
build() {
cd "$_pkgname-$pkgver"
diff --git a/linux-4.5.patch b/linux-4.5.patch
deleted file mode 100644
index ad8195a2f0f5..000000000000
--- a/linux-4.5.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/r8168_n.c b/src/r8168_n.c
-index d197630..b47419d 100755
---- a/src/r8168_n.c
-+++ b/src/r8168_n.c
-@@ -4209,7 +4209,7 @@ static netdev_features_t rtl8168_fix_features(struct net_device *dev,
- spin_lock_irqsave(&tp->lock, flags);
- if (dev->mtu > ETH_DATA_LEN) {
- features &= ~NETIF_F_ALL_TSO;
-- features &= ~NETIF_F_ALL_CSUM;
-+ features &= ~NETIF_F_CSUM_MASK;
- }
- spin_unlock_irqrestore(&tp->lock, flags);
-