summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeph2019-09-13 00:31:44 +0200
committerZeph2019-09-13 00:31:44 +0200
commit1d79af2cf43808835d2bf983b300f5221cad5b55 (patch)
tree21fd8c91088b04c1cf4f9ef34cc065cb4e357b6c
parentbbeac0db619407212a14860de6fc6fe991dcdcf3 (diff)
downloadaur-1d79af2cf43808835d2bf983b300f5221cad5b55.tar.gz
Python 3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44f3664da6d5..a5b0ec26664c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = rabbitvcs
pkgdesc = A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)
- pkgver = 0.17.1
+ pkgver = 0.17.2
pkgrel = 1
url = https://github.com/rabbitvcs/rabbitvcs
install = rabbitvcs.install
changelog = rabbitvcs.changelog
arch = any
license = GPL
- makedepends = python2-setuptools
+ makedepends = python-setuptools
depends = git
- depends = pygtk
- depends = python2-pysvn
- depends = python2-dulwich
- depends = python2-gobject2
- depends = python2-configobj
- depends = python2-simplejson
- depends = python2-gtkspellcheck
+ depends = gtk3
+ depends = python-pysvn
+ depends = python-dulwich
+ depends = python-gobject
+ depends = python-configobj
+ depends = python-simplejson
+ depends = python-gtkspellcheck
depends = tk
optdepends = meld: graphical diff viewer
- source = rabbitvcs-0.17.1.tar.gz::https://github.com/rabbitvcs/rabbitvcs/archive/v0.17.1.tar.gz
- md5sums = f34ba22c17bd487838a9f0db764d52c1
+ source = rabbitvcs-0.17.2-1.tar.gz::https://github.com/rabbitvcs/rabbitvcs/archive/e7d5a82836855675b11cc860bc9cc3ce56864ffd.tar.gz
+ sha256sums = c73d324d84ddc76dd584cc83e7040b7e234242fa72e18f46b5136f34263cd389
pkgname = rabbitvcs
diff --git a/PKGBUILD b/PKGBUILD
index 4edb83d13e1b..b7c1f907d6ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
# Maintainer: Zeph <zeph33@gmail.com>
pkgname=rabbitvcs
-pkgver=0.17.1
+pkgver=0.17.2
pkgrel=1
+_gitcommit='e7d5a82836855675b11cc860bc9cc3ce56864ffd'
pkgdesc="A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)"
arch=('any')
#url="http://rabbitvcs.org/"
url="https://github.com/rabbitvcs/rabbitvcs"
install=${pkgname}.install
changelog=${pkgname}.changelog
-depends=('git' 'pygtk' 'python2-pysvn' 'python2-dulwich' 'python2-gobject2' 'python2-configobj' 'python2-simplejson' 'python2-gtkspellcheck' 'tk')
+depends=('git' 'gtk3' 'python-pysvn' 'python-dulwich' 'python-gobject' 'python-configobj' 'python-simplejson' 'python-gtkspellcheck' 'tk')
optdepends=('meld: graphical diff viewer')
-makedepends=('python2-setuptools')
+makedepends=('python-setuptools')
license=('GPL')
-_gitcommit=""
if [ "${_gitcommit}" != "" ]; then
source=("rabbitvcs-$pkgver-$pkgrel.tar.gz::$url/archive/$_gitcommit.tar.gz")
else
source=("rabbitvcs-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
fi
-md5sums=('95b7c30945f10333588a39b5f6766136')
-#md5sums=('SKIP')
+sha256sums=('658f410d29baf615f668ff0d787e5f3769c887d3077a307b6da9d2169291fa5f')
+#sha256sums=('SKIP')
build() {
@@ -29,14 +29,15 @@ build() {
mv "$srcdir/rabbitvcs-$_gitcommit" "$srcdir/rabbitvcs-$pkgver"
fi
cd "$srcdir/$pkgname-$pkgver"
- sed -i "s#env python#env python2#" setup.py
- sed -i "s#!= 'Darwin'#== 'toto'#" setup.py
- sed -i "s#import hashlib#import hashlib, urllib#" ./rabbitvcs/util/helper.py
- find . -name "*.py" | xargs grep -l sys.executable | xargs sed -i 's|sys\.executable|"/usr/bin/python2"|g'
- python2 setup.py build
+ sed -i "s#0.17.1#${pkgver}#" ./rabbitvcs/__init__.py
+ sed -i "s#0.17.1#${pkgver}#" setup.py
+ # sed -i "s#!= 'Darwin'#== 'toto'#" setup.py
+ # sed -i "s#import hashlib#import hashlib, urllib#" ./rabbitvcs/util/helper.py
+ # find . -name "*.py" | xargs grep -l sys.executable | xargs sed -i 's|sys\.executable|"/usr/bin/python2"|g'
+ python setup.py build
}
package(){
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}