summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeph332015-06-23 13:19:33 +0200
committerZeph332015-06-23 13:19:33 +0200
commit75a7bbac347b11adc76a346b596b44437263e256 (patch)
tree6118860da9258434b00f6b50ffbb933d6b988d39
downloadaur-75a7bbac347b11adc76a346b596b44437263e256.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
-rw-r--r--rabbitvcs.changelog5
-rw-r--r--rabbitvcs.install14
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6eb0aa82b3b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = rabbitvcs
+ pkgdesc = A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)
+ pkgver = 0.16
+ pkgrel = 1
+ url = http://rabbitvcs.org/
+ install = rabbitvcs.install
+ changelog = rabbitvcs.changelog
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = git
+ depends = pygtk
+ depends = python2-pysvn
+ depends = python2-dulwich
+ depends = python2-gobject2
+ depends = python2-configobj
+ depends = python2-simplejson
+ depends = python2-gtkspellcheck
+ optdepends = meld: graphical diff viewer
+ source = https://github.com/rabbitvcs/rabbitvcs/archive/v0.16.tar.gz
+ md5sums = 25376cff136ad2fac901ff88e07893ef
+
+pkgname = rabbitvcs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f3fa20fa402
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Thomas Oster <thomas.oster@rwth-aachen.de>
+# Maintainer: Zeph <zeph33@gmail.com>
+
+pkgname=rabbitvcs
+pkgver=0.16
+pkgrel=1
+pkgdesc="A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)"
+arch=('any')
+url="http://rabbitvcs.org/"
+install=${pkgname}.install
+changelog=${pkgname}.changelog
+depends=('git' 'pygtk' 'python2-pysvn' 'python2-dulwich' 'python2-gobject2' 'python2-configobj' 'python2-simplejson' 'python2-gtkspellcheck')
+optdepends=('meld: graphical diff viewer')
+makedepends=('python2-setuptools')
+license=('GPL')
+source=("https://github.com/rabbitvcs/rabbitvcs/archive/v0.16.tar.gz")
+md5sums=('25376cff136ad2fac901ff88e07893ef')
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i "s#env python#env python2#" setup.py
+ find . -name "*.py" | xargs grep -l sys.executable | xargs sed -i 's|sys\.executable|"/usr/bin/python2"|g'
+ python2 setup.py build
+}
+
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
diff --git a/rabbitvcs.changelog b/rabbitvcs.changelog
new file mode 100644
index 000000000000..346ae6a2aeb3
--- /dev/null
+++ b/rabbitvcs.changelog
@@ -0,0 +1,5 @@
+2014-29-01 Zeph <zeph33@gmail.com>
+
+ * 0.15.3-4 :
+ added ChangeLog.
+ added patch for git folder shows bomb emblem
diff --git a/rabbitvcs.install b/rabbitvcs.install
new file mode 100644
index 000000000000..e8978309c959
--- /dev/null
+++ b/rabbitvcs.install
@@ -0,0 +1,14 @@
+post_install(){
+gtk-update-icon-cache /usr/share/icons/hicolor/
+cat << _EOF
+=> This is the RabbitCVS core version. When installing RabbitVCS, you must install the core package as well as a package for each front-end you wish to use.
+_EOF
+}
+
+post_upgrade(){
+gtk-update-icon-cache /usr/share/icons/hicolor/
+}
+
+post_remove(){
+gtk-update-icon-cache /usr/share/icons/hicolor/
+}