summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2024-03-09 12:17:13 +0100
committerChristian Schendel2024-03-09 12:17:13 +0100
commit6009a7448237c02b4558a8bbb7d52eb9b4051886 (patch)
tree508c828ace14ca2e3f9bd6b405d14f0f5e66f645
parent4da70fe9838870272a2ccabf381396603ead7845 (diff)
downloadaur-6009a7448237c02b4558a8bbb7d52eb9b4051886.tar.gz
Make sure this builds in a chroot environment
modified: .SRCINFO modified: .gitignore modified: PKGBUILD new file: chroot-build.sh
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD207
-rwxr-xr-xchroot-build.sh24
4 files changed, 151 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 063881b26108..16dab4722eae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = rabbitvcs-git
pkgdesc = A set of graphical tools written to provide simple and straightforward access to the version control systems you use
- pkgver = r1906.51cd7a3
+ pkgver = r1935.f3da1d7
pkgrel = 1
url = https://github.com/rabbitvcs/rabbitvcs
arch = any
license = GPL
makedepends = git
makedepends = python-setuptools
+ makedepends = gtk-update-icon-cache
source = rabbitvcs::git+https://github.com/rabbitvcs/rabbitvcs.git
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index cc75a9f7d29e..9b312b2ccc10 100644
--- a/.gitignore
+++ b/.gitignore
@@ -8,4 +8,5 @@
!rabbitvcs-thunar.install
!.gitignore
!.SRCINFO
+!chroot-build.sh
diff --git a/PKGBUILD b/PKGBUILD
index 1a410a9ea615..03bbad396bdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,117 +10,158 @@
pkgbase='rabbitvcs-git'
-pkgname=('rabbitvcs-git'
- 'rabbitvcs-cli-git'
- 'rabbitvcs-caja-git'
- 'rabbitvcs-nautilus-git'
- 'rabbitvcs-nemo-git'
- 'rabbitvcs-thunar-git')
-
-pkgver=r1906.51cd7a3
+pkgname=(
+ 'rabbitvcs-git'
+ 'rabbitvcs-cli-git'
+ 'rabbitvcs-caja-git'
+ 'rabbitvcs-nautilus-git'
+ 'rabbitvcs-nemo-git'
+ 'rabbitvcs-thunar-git'
+)
+
+pkgver=r1935.f3da1d7
pkgrel=1
pkgdesc="A set of graphical tools written to provide simple and straightforward access to the version control systems you use"
arch=('any')
url="https://github.com/rabbitvcs/rabbitvcs"
-source=("${pkgbase%-git}::git+${url}.git")
-makedepends=('git'
- 'python-setuptools')
+source=(
+ "${pkgbase%-git}::git+${url}.git"
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
+ 'gtk-update-icon-cache'
+)
license=('GPL')
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgbase%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "${srcdir}/${pkgbase%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- cd "$srcdir/${pkgbase%-git}"
- python setup.py build
+ cd "$srcdir/${pkgbase%-git}"
+ python setup.py build
}
package_rabbitvcs-git(){
- depends=('git'
- 'gtk3'
- 'python-configobj'
- 'python-dulwich'
- 'python-gobject'
- 'python-pysvn'
- 'python-simplejson'
- 'tk')
- optdepends=('meld: graphical diff tool'
- 'python-pygments: For syntax highlighting'
- 'python-gtkspellcheck: For spell checking of commit messages'
- 'hunspell: For spell checking of commit messages')
- provides=('rabbitvcs')
- conflicts=('rabbitvcs')
-
- cd "$srcdir/${pkgbase%-git}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ depends=(
+ 'git'
+ 'gtk3'
+ 'python-configobj'
+ 'python-dulwich'
+ 'python-gobject'
+ 'python-pysvn'
+ 'python-simplejson'
+ 'tk'
+ )
+ optdepends=(
+ 'meld: graphical diff tool'
+ 'python-pygments: For syntax highlighting'
+ 'python-gtkspellcheck: For spell checking of commit messages'
+ 'hunspell: For spell checking of commit messages'
+ )
+ provides=(
+ 'rabbitvcs'
+ )
+ conflicts=(
+ 'rabbitvcs'
+ )
+
+ cd "$srcdir/${pkgbase%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
package_rabbitvcs-cli-git() {
- pkgdesc="A command line client for RabbitVCS"
- depends=('rabbitvcs')
- provides=('rabbitvcs-cli')
- conflicts=('rabbitvcs-cli')
-
- cd "$srcdir/${pkgbase%-git}"
- install -Dm755 "clients/cli/${pkgbase%-git}" -t \
- "$pkgdir/usr/bin"
+ pkgdesc="A command line client for RabbitVCS"
+ depends=(
+ 'rabbitvcs'
+ )
+ provides=(
+ 'rabbitvcs-cli'
+ )
+ conflicts=(
+ 'rabbitvcs-cli'
+ )
+
+ cd "$srcdir/${pkgbase%-git}"
+ install -Dm755 "clients/cli/${pkgbase%-git}" -t \
+ "$pkgdir/usr/bin"
}
package_rabbitvcs-caja-git() {
- pkgdesc="Caja extension for RabbitVCS"
- depends=('dbus-python' 'python-caja' 'rabbitvcs')
- provides=('rabbitvcs-caja')
- conflicts=('rabbitvcs-caja')
- install="${pkgname%-git}.install"
-
- cd "$srcdir/${pkgbase%-git}"
- install -Dm644 clients/caja/RabbitVCS.py -t \
- "$pkgdir/usr/share/caja-python/extensions"
+ pkgdesc="Caja extension for RabbitVCS"
+ depends=(
+ 'dbus-python'
+ 'python-caja'
+ 'rabbitvcs'
+ )
+ provides=(
+ 'rabbitvcs-caja'
+ )
+ conflicts=(
+ 'rabbitvcs-caja'
+ )
+ install="${pkgname%-git}.install"
+
+ cd "$srcdir/${pkgbase%-git}"
+ install -Dm644 clients/caja/RabbitVCS.py -t \
+ "$pkgdir/usr/share/caja-python/extensions"
}
package_rabbitvcs-nautilus-git() {
- pkgdesc="Nautilus extension for RabbitVCS"
- depends=('dbus-python'
- 'python-nautilus'
- 'rabbitvcs')
- provides=('rabbitvcs-nautilus')
- conflicts=('rabbitvcs-nautilus')
- install="${pkgname%-git}.install"
-
- cd "$srcdir/${pkgbase%-git}"
- install -Dm644 clients/nautilus/RabbitVCS.py -t \
- "$pkgdir/usr/share/nautilus-python/extensions"
+ pkgdesc="Nautilus extension for RabbitVCS"
+ depends=(
+ 'dbus-python'
+ 'python-nautilus'
+ 'rabbitvcs'
+ )
+ provides=(
+ 'rabbitvcs-nautilus'
+ )
+ conflicts=(
+ 'rabbitvcs-nautilus'
+ )
+ install="${pkgname%-git}.install"
+ cd "$srcdir/${pkgbase%-git}"
+ install -Dm644 clients/nautilus/RabbitVCS.py -t \
+ "$pkgdir/usr/share/nautilus-python/extensions"
}
package_rabbitvcs-nemo-git() {
- pkgdesc="Nemo extension for RabbitVCS"
- depends=('dbus-python'
- 'nemo-python'
- 'rabbitvcs')
- provides=('rabbitvcs-nemo')
- conflicts=('rabbitvcs-nemo')
- install="${pkgname%-git}.install"
-
- cd "$srcdir/${pkgbase%-git}"
- install -Dm644 clients/nemo/RabbitVCS.py -t \
- "$pkgdir/usr/share/nemo-python/extensions"
+ pkgdesc="Nemo extension for RabbitVCS"
+ depends=(
+ 'dbus-python'
+ 'nemo-python'
+ 'rabbitvcs'
+ )
+ provides=(
+ 'rabbitvcs-nemo'
+ )
+ conflicts=(
+ 'rabbitvcs-nemo'
+ )
+ install="${pkgname%-git}.install"
+ cd "$srcdir/${pkgbase%-git}"
+ install -Dm644 clients/nemo/RabbitVCS.py -t \
+ "$pkgdir/usr/share/nemo-python/extensions"
}
package_rabbitvcs-thunar-git() {
- pkgdesc="Thunar extension for RabbitVCS"
- depends=('dbus-python'
- 'rabbitvcs'
- 'thunarx-python')
- install="${pkgname%-git}.install"
-
- cd "$srcdir/${pkgbase%-git}"
- install -Dm644 clients/thunar/RabbitVCS.py -t \
- "$pkgdir/usr/share/thunarx-python/extensions"
+ pkgdesc="Thunar extension for RabbitVCS"
+ depends=(
+ 'dbus-python'
+ 'rabbitvcs'
+ 'thunarx-python'
+ )
+ install="${pkgname%-git}.install"
+ cd "$srcdir/${pkgbase%-git}"
+ install -Dm644 clients/thunar/RabbitVCS.py -t \
+ "$pkgdir/usr/share/thunarx-python/extensions"
}
+# vim:set softtabstop=4 shiftwidth=4 tabstop=4 expandtab:
diff --git a/chroot-build.sh b/chroot-build.sh
new file mode 100755
index 000000000000..387e418a5e5a
--- /dev/null
+++ b/chroot-build.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+# This script updates the package version if a new version is available
+set -euxo pipefail
+
+# Preparing arch-chroot
+CHROOT=$HOME/.local/share/chroot
+if [[ ! -d "$CHROOT" ]]; then
+ mkdir -p ~/.local/share/chroot
+ mkarchroot $HOME/.local/share/chroot/root base-devel
+ arch-nspawn $HOME/.local/share/chroot/root pacman -Syu
+fi
+
+# Start generate package
+makechrootpkg -c -r $CHROOT -- -Acsf .
+
+# Update .SRCINFO
+#makepkg --printsrcinfo >.SRCINFO
+
+# Commit changes
+#git add PKGBUILD .SRCINFO
+#git commit -s -m "Update to ${VER}"
+#rm -rf *.gz *.log *.zst
+sudo rm -Rf "$CHROOT"