summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeph2017-06-23 17:33:29 +0000
committerZeph2017-06-23 17:33:29 +0000
commitf89a4b02cf2e0a0acca3ad307091921ebae89016 (patch)
treea404fefa7c5ce6a7ecd8dc099ae85313e1c4c8c6
parent5e961b76a8646329bc080314d6793c2b887b3bce (diff)
downloadaur-f89a4b02cf2e0a0acca3ad307091921ebae89016.tar.gz
MD5 error
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb14c7d812bb..ceb0994a1dba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,14 +2,14 @@ pkgbase = rabbitvcs-nemo
pkgdesc = Nemo front-end for rabbitvcs SVN GIT HG Extension.
pkgver = 0.16
pkgrel = 3
- url = http://rabbitvcs.org/
+ url = https://github.com/rabbitvcs/rabbitvcs
install = rabbitvcs-nemo.install
arch = any
license = GPL
depends = nemo-python>=2.0
depends = python2-dbus
depends = rabbitvcs>=0.16
- source = rabbitvcs-0.16-3.tar.gz::http://rabbitvcs.org//archive/4e94b82e34b409f0baced88521a6e03cb29c4155.tar.gz
+ source = rabbitvcs-0.16-3.tar.gz::https://github.com/rabbitvcs/rabbitvcs/archive/4e94b82e34b409f0baced88521a6e03cb29c4155.tar.gz
md5sums = 9669132c6ef3f21ecfe1fd96b9be3e0d
pkgname = rabbitvcs-nemo
diff --git a/PKGBUILD b/PKGBUILD
index e99181c414a7..975591adaf9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc="Nemo front-end for rabbitvcs SVN GIT HG Extension."
pkgver=0.16
pkgrel=3
arch=('any')
-url="http://rabbitvcs.org/"
+url="https://github.com/rabbitvcs/rabbitvcs"
install=$pkgname.install
depends=('nemo-python>=2.0' 'python2-dbus' "rabbitvcs>=$pkgver")
license=('GPL')
@@ -17,6 +17,12 @@ else
fi
md5sums=('9669132c6ef3f21ecfe1fd96b9be3e0d')
+build() {
+ if [ "$_gitcommit" != "" ]; then
+ mv "$srcdir/rabbitvcs-$_gitcommit" "$srcdir/rabbitvcs-$pkgver"
+ fi
+}
+
package(){
install -D "$srcdir/rabbitvcs-$pkgver/clients/nemo/RabbitVCS.py" "$pkgdir/usr/share/nemo-python/extensions/RabbitVCS.py"
}