summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCan Celasun2015-05-31 21:46:22 +0300
committerCan Celasun2015-05-31 21:46:22 +0300
commit45a5a2369d8b95c6e837f9e0c540f78b241063c2 (patch)
tree5eec379d2a03756b7316f3971e41849dae3eebfe
downloadaur-45a5a2369d8b95c6e837f9e0c540f78b241063c2.tar.gz
New structure
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..115646267443
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rabbitvcs-thunar
+ pkgdesc = Thunar front-end for RabbitVCS
+ pkgver = 0.16
+ pkgrel = 1
+ url = http://rabbitvcs.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = thunar>=0.4.0
+ depends = thunarx-python>=0.2.0
+ depends = dbus-python>=0.80
+ depends = rabbitvcs>=0.16
+ source = https://github.com/rabbitvcs/rabbitvcs/archive/v0.16.tar.gz
+ md5sums = 25376cff136ad2fac901ff88e07893ef
+
+pkgname = rabbitvcs-thunar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70e669f1c95d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+#Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+#Contributor: Dmitry Batenkov <dima dot batenkov at gmail dot com>
+
+pkgname=rabbitvcs-thunar
+pkgver=0.16
+pkgrel=1
+pkgdesc="Thunar front-end for RabbitVCS"
+arch=('i686' 'x86_64')
+url="http://rabbitvcs.org/"
+depends=('thunar>=0.4.0' 'thunarx-python>=0.2.0' 'dbus-python>=0.80' "rabbitvcs>=${pkgver}")
+license=('GPL')
+source=(https://github.com/rabbitvcs/rabbitvcs/archive/v${pkgver}.tar.gz)
+md5sums=('25376cff136ad2fac901ff88e07893ef')
+package(){
+ cd ${srcdir}/rabbitvcs-${pkgver}
+ mkdir -p $pkgdir/usr/lib/thunarx-2/python
+ mkdir -p $pkgdir/usr/lib/thunarx-1/python
+ sed -i '1i #!/usr/bin/env python2' clients/thunar/RabbitVCS.py
+ cp clients/thunar/RabbitVCS.py $pkgdir/usr/lib/thunarx-2/python
+ cp clients/thunar/RabbitVCS.py $pkgdir/usr/lib/thunarx-1/python
+}