summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre ZANNI2020-03-17 19:26:30 +0100
committerAlexandre ZANNI2020-03-17 19:26:30 +0100
commite5664d27569e4009952bb777bb028abe9c8d86c3 (patch)
tree25b27fd023a3c2e76c0ecdd80966d1d334f872f1
parent382f4facae74a96ac4d566ff56fb6c6f25722019 (diff)
parentb62419e7cb7eed6238e5bcb23940048ef5d5eeff (diff)
downloadaur-e5664d27569e4009952bb777bb028abe9c8d86c3.tar.gz
bump to 0.0.5
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
-rw-r--r--rabid.install11
3 files changed, 22 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a55186ca7b9..e793e7300291 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = rabid
- pkgdesc = A CLI tool and library allowing to simply decode all kind of BigIP cookies.
+ pkgdesc = A CLI tool and library allowing to simply decode all kind of BigIP cookies
pkgver = 0.0.5
pkgrel = 1
url = https://orange-cyberdefense.github.io/rabid/
- install = rabid.install
arch = any
license = MIT
depends = ruby
- depends = ruby-bundler
- depends = libxslt
- provides = rabid
- conflicts = rabid-git
- source = https://github.com/Orange-Cyberdefense/rabid/archive/v0.0.5.tar.gz
- sha512sums = 3ff94abff0e15ca3a3053434955f5b7ce70d9db01e2288e87e940f0d95cb3fe1c3dd61988abd14e6ebf74853f8e6e95af42e3a5f6478a3be082de61e991ea64f
+ depends = ruby-paint
+ depends = ruby-docopt
+ noextract = rabid-0.0.5.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/rabid-0.0.5.gem
+ b2sums = e9c69aa492e2ed09fc3e84d52663780c05ee99c01c6d9c9f85dfab0b2f38e3cfbcf8c0c964206d4c79817804e7ce0d0ace8cdc140aecd184877efe7367d84ff5
pkgname = rabid
diff --git a/PKGBUILD b/PKGBUILD
index 69569bc83322..5f063fb70e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,47 +3,28 @@
pkgname=rabid
pkgver=0.0.5
pkgrel=1
-pkgdesc='A CLI tool and library allowing to simply decode all kind of BigIP cookies.'
+pkgdesc='A CLI tool and library allowing to simply decode all kind of BigIP cookies'
arch=('any')
url='https://orange-cyberdefense.github.io/rabid/'
license=('MIT')
-depends=('ruby' 'ruby-bundler' 'libxslt')
-conflicts=('rabid-git')
-provides=('rabid')
-source=("https://github.com/Orange-Cyberdefense/$pkgname/archive/v$pkgver.tar.gz")
-sha512sums=('3ff94abff0e15ca3a3053434955f5b7ce70d9db01e2288e87e940f0d95cb3fe1c3dd61988abd14e6ebf74853f8e6e95af42e3a5f6478a3be082de61e991ea64f')
-install="$pkgname.install"
+depends=('ruby' 'ruby-paint' 'ruby-docopt')
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/$pkgname-$pkgver.gem")
+#source=("https://github.com/Orange-Cyberdefense/$pkgname/archive/v$pkgver.tar.gz")
+noextract=("$pkgname-$pkgver.gem")
+b2sums=('e9c69aa492e2ed09fc3e84d52663780c05ee99c01c6d9c9f85dfab0b2f38e3cfbcf8c0c964206d4c79817804e7ce0d0ace8cdc140aecd184877efe7367d84ff5')
package() {
- cd "$pkgname-$pkgver"
+ _gemdir="$(ruby -e'puts Gem.default_dir')"
- install -dm 755 "$pkgdir/usr/bin"
- install -dm 755 "$pkgdir/usr/share/$pkgname"
+ gem install --ignore-dependencies --no-user-install --no-document \
+ -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $pkgname-$pkgver.gem
- install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname" *.md
- install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm "$pkgdir/$_gemdir/cache/$pkgname-$pkgver.gem"
+ find "$pkgdir/$_gemdir/extensions/" -name *.so -delete
+ rm -r "$pkgdir/$_gemdir/gems/$pkgname-$pkgver/test"
- cp -a docs/* "$pkgdir/usr/share/doc/$pkgname/"
-
- rm -rf *.md LICENSE.txt docs
-
- cp -a * "$pkgdir/usr/share/$pkgname/"
- cp -a .gitignore .rubocop.yml .yardopts .yardopts-dev "$pkgdir/usr/share/$pkgname/"
-
- cat > "$pkgdir/usr/bin/$pkgname" << EOF
-#!/bin/sh
-cd /usr/share/$pkgname
-exec bundle exec ./bin/$pkgname "\$@"
-EOF
-
- chmod a+x "$pkgdir/usr/bin/$pkgname"
-
- cat > "$pkgdir/usr/bin/$pkgname-console" << EOF
-#!/bin/sh
-cd /usr/share/$pkgname
-exec bundle exec ./bin/${pkgname}_console "\$@"
-EOF
-
- chmod a+x "$pkgdir/usr/bin/$pkgname-console"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$pkgname-$pkgver/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/rabid.install b/rabid.install
deleted file mode 100644
index a4fc56fc02fb..000000000000
--- a/rabid.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- set -e
- cd /usr/share/rabid
- rm -f Gemfile.lock
- bundle config build.nokogiri --use-system-libraries
- bundle install --path vendor/bundle
-}
-
-post_upgrade() {
- post_install "$@"
-}