summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaja Mukherji2018-08-06 08:22:37 +0100
committerRaja Mukherji2018-08-06 08:22:37 +0100
commitbb34f9f7713ac1d462de5921dbba1dde62a9b18c (patch)
treef999c615ccc3b7d9d17d8025be275a49fe256e8d
downloadaur-bb34f9f7713ac1d462de5921dbba1dde62a9b18c.tar.gz
initial import into AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc5959f61aa9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rabs
+ pkgdesc = Generic imperative build system
+ pkgver = 1.2.0
+ pkgrel = 1
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = gc
+ depends = sqlite
+ provides = rabs
+ source = git+https://github.com/wrapl/rabs#tag=v1.2.0
+ md5sums = SKIP
+
+pkgname = rabs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b37731a9d910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=rabs
+pkgver=1.2.0
+pkgrel=1
+epoch=
+pkgdesc="Generic imperative build system"
+arch=('x86_64' 'i686')
+url=""
+license=('MIT')
+groups=()
+depends=('gc' 'sqlite')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=('rabs')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/wrapl/$pkgname#tag=v$pkgver")
+noextract=()
+md5sums=(SKIP)
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+check() {
+ cd "$pkgname"
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir/" install
+}