summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-09-01 12:30:34 +0800
committerChocobo12020-09-01 13:51:31 +0800
commitf373c15c1f801f1ecfee404e27b71327bc84ef01 (patch)
treef179a4328a130cd03e9f5dd680c7bbfe81241136
downloadaur-f373c15c1f801f1ecfee404e27b71327bc84ef01.tar.gz
newpkg: racon 1.4.13-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cd72ff36246
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = racon
+ pkgdesc = Ultrafast consensus module for raw de novo genome assembly
+ pkgver = 1.4.13
+ pkgrel = 1
+ url = https://github.com/lbcb-sci/racon
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ provides = racon
+ conflicts = racon
+ source = git+https://github.com/lbcb-sci/racon.git#tag=1.4.13
+ sha256sums = SKIP
+
+pkgname = racon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a44673c4600
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=racon
+pkgver=1.4.13
+pkgrel=1
+pkgdesc="Ultrafast consensus module for raw de novo genome assembly"
+arch=('i686' 'x86_64')
+url="https://github.com/lbcb-sci/racon"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('git' 'cmake')
+provides=('racon')
+conflicts=('racon')
+source=("git+https://github.com/lbcb-sci/racon.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "racon"
+
+ git submodule update --init --recursive
+
+ # workaround for compile error
+ cd "vendor/spoa"
+ git checkout "tags/3.2.0"
+}
+
+build() {
+ cd "racon"
+
+ mkdir -p "_build" && cd "_build"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ "../"
+ make
+}
+
+package() {
+ cd "racon"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/racon"
+}