summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorschrotthaufen2015-07-15 18:19:45 +0200
committerschrotthaufen2015-07-15 18:19:45 +0200
commitb577a16b41af1d0884f0ef5d75b2d18cc65337fe (patch)
tree0f355b77881ee069a5ac18055b7a8bfad9a56201
parentf7e597927aae4a639e4ad14b993bd1f52af9a15d (diff)
downloadaur-b577a16b41af1d0884f0ef5d75b2d18cc65337fe.tar.gz
Fix dependencies according to guidelines
Removed ./autogen.sh line, since 1) it's not strictly neccessary 2) it requires acr to be installed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba2fd2067786..f6ee8a278114 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radare2-git
pkgdesc = Open-source tools to disasm, debug, analyze and manipulate binary files
- pkgver = 20150622.8220.d436d16
+ pkgver = 20150715.8475.d4eb221
pkgrel = 1
url = http://radare.org
arch = i686
@@ -8,7 +8,7 @@ pkgbase = radare2-git
license = GPL3
license = LGPL3
makedepends = git
- depends = capstone-git
+ depends = capstone
provides = radare2
conflicts = radare2
source = radare2-git::git://github.com/radare/radare2.git
diff --git a/PKGBUILD b/PKGBUILD
index 9c547eea97dd..724f65c414f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# with fixes by 0xAA <0xaa@dmg.sx>
pkgname="radare2-git"
-pkgver=20150622.8220.d436d16
+pkgver=20150715.8475.d4eb221
pkgrel=1
pkgdesc="Open-source tools to disasm, debug, analyze and manipulate binary files"
arch=('i686' 'x86_64')
url="http://radare.org"
license=('GPL3' 'LGPL3')
makedepends=('git')
-depends=('capstone-git')
-provides=('radare2')
+depends=('capstone')
+provides=('radare2') # capstone-git is reccomended
conflicts=('radare2')
source=("$pkgname"::"git://github.com/radare/radare2.git")
@@ -34,7 +34,7 @@ build() {
# installation. Unfortunately linking syscapstone is broken and the
# build system always clones capstone and links against this instead.
#CFGARG="--with-syscapstone" ./sys/build.sh
- ./autogen.sh
+ #./autogen.sh # needs acr
./configure --with-syscapstone --with-openssl --prefix=/usr
make
#./sys/build.sh