summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorschrotthaufen2015-07-04 14:49:16 +0200
committerschrotthaufen2015-07-04 14:49:16 +0200
commitf7e597927aae4a639e4ad14b993bd1f52af9a15d (patch)
treec28b252c14bcc3b0d0eeef961f723ada3c7aa769
downloadaur-f7e597927aae4a639e4ad14b993bd1f52af9a15d.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba2fd2067786
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = radare2-git
+ pkgdesc = Open-source tools to disasm, debug, analyze and manipulate binary files
+ pkgver = 20150622.8220.d436d16
+ pkgrel = 1
+ url = http://radare.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ makedepends = git
+ depends = capstone-git
+ provides = radare2
+ conflicts = radare2
+ source = radare2-git::git://github.com/radare/radare2.git
+ md5sums = SKIP
+
+pkgname = radare2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c547eea97dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# with fixes by 0xAA <0xaa@dmg.sx>
+pkgname="radare2-git"
+pkgver=20150622.8220.d436d16
+pkgrel=1
+pkgdesc="Open-source tools to disasm, debug, analyze and manipulate binary files"
+arch=('i686' 'x86_64')
+url="http://radare.org"
+license=('GPL3' 'LGPL3')
+makedepends=('git')
+depends=('capstone-git')
+provides=('radare2')
+conflicts=('radare2')
+
+source=("$pkgname"::"git://github.com/radare/radare2.git")
+md5sums=('SKIP')
+
+pkgver () {
+ _date=`date +"%Y%m%d"`
+ cd "${srcdir}/${pkgname}"
+ echo "$_date.$(git rev-list --count master).$(git rev-parse --short master)"
+}
+
+build() {
+# not sure if those are still needed
+ export CFLAGS="${CFLAGS//-fPIE -pie}"
+ export CXXFLAGS="${CXXFLAGS//-fPIE -pie}"
+ # this is actually needed to prevent linking against old system-wide r2 libs
+ # you can comment this out, if you build in a clean environment
+ export PKG_CONFIG_PATH="${srcdir}/${pkgname}/pkgcfg:${PKG_CONFIG_PATH}"
+
+ cd ${srcdir}/${pkgname}
+ # in theory explicitly passing --with-syscapstone shouldn't be needed
+ # anymore, as ./sys/build.sh checks for a suitable system wide capstone
+ # installation. Unfortunately linking syscapstone is broken and the
+ # build system always clones capstone and links against this instead.
+ #CFGARG="--with-syscapstone" ./sys/build.sh
+ ./autogen.sh
+ ./configure --with-syscapstone --with-openssl --prefix=/usr
+ make
+ #./sys/build.sh
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ make DESTDIR=${pkgdir} install
+ install -D -m644 man/* "${pkgdir}/usr/share/man/man1"
+ rm -rf ${srcdir}/${pkgname}
+}