summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2018-03-16 09:27:13 -0700
committerDonald Webster2018-03-16 12:53:00 -0700
commita161361e541a10fb89bea6977711c83c9ecadd92 (patch)
treea7f46cf1316a25661eb3c385344d29d39a285b12
parente95715aedf863dce657aa0a613d8ccac77de4522 (diff)
downloadaur-a161361e541a10fb89bea6977711c83c9ecadd92.tar.gz
Switch to systemds tmpfiles.
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
-rw-r--r--radarr.install11
-rw-r--r--radarr.tmpfiles3
5 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c43ae5563f9..5043d73f48c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = radarr
pkgdesc = Movie downloader for usenet and torrents.
pkgver = 0.2.0.995
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/galli-leo/Radarr
- install = radarr.install
arch = any
license = GPL3
depends = mono
@@ -20,9 +19,11 @@ pkgbase = radarr
optdepends = libgdiplus: provides a gdi+ compatible api
source = https://github.com/galli-leo/Radarr/releases/download/v0.2.0.995/Radarr.develop.0.2.0.995.linux.tar.gz
source = radarr.service
+ source = radarr.tmpfiles
source = radarr.sysusers
sha512sums = 1d558e72f629e304d0bfccdf999d9ca78a81cbfaf1b3d41ae495d181997a8bb03d8c6cde07ae270b8f86f4f2b4cecdf43361d6c22ece2997c1f220ad5624269d
sha512sums = 8dd2b91252a87d70e41487951ec89c7a0448fc06c7c7c2182ed6463b7f508c0c638d3c0413b7e6c74bfabfc12eb2e25aa9c1e1024e895766372d4e2e7ed67335
+ sha512sums = f6b0e13f334d96854dd28f53d4c45efbca50bc2eeed0f172f81295b105fa18e5a9370dbbef1a46ac11bb5f58ebeb045db14985d9ab902bcd4a4bb0bd2d16da51
sha512sums = c1ee3925eced182ea7fffa55a6dc2a4e099ccf18636fc237ef0a2fc9517a38cfc2a819ae5a7bc546b63e383506f9f47e89454a71e34106c579d7454d71b2299e
pkgname = radarr
diff --git a/.gitignore b/.gitignore
index 126ef55ce320..6e570bc49abe 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.xz
*.gz
+*.log
/src/
/pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 7356a79aba65..dfafc96c0e98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Devin Buhl <devin.kray@gmail.com>
pkgname="radarr"
pkgver="0.2.0.995"
-pkgrel=1
+pkgrel=2
pkgdesc="Movie downloader for usenet and torrents."
arch=(any)
url="https://github.com/galli-leo/Radarr"
@@ -17,25 +17,23 @@ optdepends=('sabnzbd: usenet downloader'
'rtorrent: torrent downloader'
'jackett: torrent indexer proxy'
'libgdiplus: provides a gdi+ compatible api')
-install='radarr.install'
+
source=("https://github.com/galli-leo/Radarr/releases/download/v${pkgver}/Radarr.develop.${pkgver}.linux.tar.gz"
"radarr.service"
+ "radarr.tmpfiles"
"radarr.sysusers")
-noextract=()
sha512sums=('1d558e72f629e304d0bfccdf999d9ca78a81cbfaf1b3d41ae495d181997a8bb03d8c6cde07ae270b8f86f4f2b4cecdf43361d6c22ece2997c1f220ad5624269d'
'8dd2b91252a87d70e41487951ec89c7a0448fc06c7c7c2182ed6463b7f508c0c638d3c0413b7e6c74bfabfc12eb2e25aa9c1e1024e895766372d4e2e7ed67335'
+ 'f6b0e13f334d96854dd28f53d4c45efbca50bc2eeed0f172f81295b105fa18e5a9370dbbef1a46ac11bb5f58ebeb045db14985d9ab902bcd4a4bb0bd2d16da51'
'c1ee3925eced182ea7fffa55a6dc2a4e099ccf18636fc237ef0a2fc9517a38cfc2a819ae5a7bc546b63e383506f9f47e89454a71e34106c579d7454d71b2299e')
package() {
- cd "$srcdir"
-
- install -d -m 755 "${pkgdir}/var/lib/radarr"
install -d -m 755 "${pkgdir}/usr/lib/radarr"
cp -dpr --no-preserve=ownership "${srcdir}/Radarr/"* "${pkgdir}/usr/lib/radarr"
-
find "${pkgdir}/usr/lib/radarr" -type f -exec chmod 644 '{}' ';'
install -D -m 644 "${srcdir}/radarr.service" "${pkgdir}/usr/lib/systemd/system/radarr.service"
- install -Dm644 "$srcdir/radarr.sysusers" "$pkgdir/usr/lib/sysusers.d/radarr.conf"
+ install -D -m 644 "${srcdir}/radarr.sysusers" "${pkgdir}/usr/lib/sysusers.d/radarr.conf"
+ install -D -m 644 "${srcdir}/radarr.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/radarr.conf"
}
diff --git a/radarr.install b/radarr.install
deleted file mode 100644
index 80c04ab0cde7..000000000000
--- a/radarr.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- systemd-sysusers radarr.conf
-
- mkdir -p /var/lib/radarr
- chown -R radarr:radarr /var/lib/radarr /usr/lib/radarr
-}
-
-post_upgrade() {
- post_install $1
-}
-
diff --git a/radarr.tmpfiles b/radarr.tmpfiles
new file mode 100644
index 000000000000..d913ce97fef2
--- /dev/null
+++ b/radarr.tmpfiles
@@ -0,0 +1,3 @@
+d /var/lib/radarr 0755 radarr radarr
+Z /var/lib/radarr - radarr radarr
+Z /usr/lib/radarr - radarr radarr