summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarazmista2015-06-09 18:50:46 +0200
committermarazmista2015-06-09 18:50:46 +0200
commita865c049cac9a11f2a2cf406929a5227257de36c (patch)
treed5bdcba8b3587cd81f162d73acc4ea073ea395c5
downloadaur-a865c049cac9a11f2a2cf406929a5227257de36c.tar.gz
Initial AUR4 import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d95e0c20046
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = radeon-profile-git
+ pkgdesc = App for display info about radeon card
+ pkgver = 20150507
+ pkgrel = 1
+ url = http://github.com/marazmista/radeon-profile
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = qt4
+ optdepends = radeon-profile-daemon: system daemon for reading card info
+ optdepends = lm_sensors: to show gpu temperature
+ optdepends = sudo: start with root privilages without password
+ optdepends = mesa-demos: for glxinfo
+ optdepends = xorg-xdriinfo: display driver name
+ optdepends = xorg-xrandr: show card connected outputs
+ optdepends = xf86-video-ati: radeon open source driver
+ provides = radeon-profile
+ replaces = radeon-profile
+ source = git://github.com/marazmista/radeon-profile.git
+ sha256sums = SKIP
+
+pkgname = radeon-profile-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97fadab3add9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: marazmista <marazmista@gmail.com>
+
+pkgname=radeon-profile-git
+pkgver=20150507
+pkgrel=1
+pkgdesc="App for display info about radeon card"
+url="http://github.com/marazmista/radeon-profile"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('qt4')
+optdepends=('radeon-profile-daemon: system daemon for reading card info'
+ 'lm_sensors: to show gpu temperature'
+ 'sudo: start with root privilages without password'
+ 'mesa-demos: for glxinfo'
+ 'xorg-xdriinfo: display driver name'
+ 'xorg-xrandr: show card connected outputs'
+ 'xf86-video-ati: radeon open source driver')
+provides=('radeon-profile')
+replaces=('radeon-profile')
+source=('git://github.com/marazmista/radeon-profile.git')
+sha256sums=('SKIP')
+
+build() {
+mkdir -p build
+cd build
+qmake-qt4 "../radeon-profile/radeon-profile/"
+make
+}
+
+package() {
+cd build
+make prefix="${pkgdir}" install
+
+install -Dm644 "$srcdir/build/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
+chmod +x "$pkgdir/usr/bin/radeon-profile"
+
+install -Dm644 "$srcdir/radeon-profile/radeon-profile/extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
+install -Dm644 "$srcdir/radeon-profile/radeon-profile/extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
+} \ No newline at end of file