summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Van Albert2018-11-02 19:03:06 -0400
committerEric Van Albert2018-11-02 19:03:06 -0400
commitba9eebb7d883f0f18b4d5ddbd6cc5bd196710beb (patch)
tree24a5c013873d9d436072cbede6e7c609b97f2011
parentf5d328965551e9bc6b59d6c68c7901cd8ad32bca (diff)
downloadaur-ba9eebb7d883f0f18b4d5ddbd6cc5bd196710beb.tar.gz
ugh, fixed the release on github
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--fix-cmake.patch16
3 files changed, 7 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0962882ddcc..3f639b626c77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = radiance
pkgdesc = Video art software for live performance
pkgver = 0.6.0
- pkgrel = 0
+ pkgrel = 1
url = https://radiance.video
arch = x86_64
license = MIT
@@ -17,10 +17,8 @@ pkgbase = radiance
depends = youtube-dl
source = https://github.com/zbanks/radiance/archive/0.6.0.tar.gz
source = https://github.com/zbanks/BTrack/archive/stable-201810.tar.gz
- source = fix-cmake.patch
- sha256sums = 5b0b780e92f2303d38c447a1efee3ab58ecbb6a106dd54d810945a5d8673ffb0
+ sha256sums = 1b4be7cfecff3e8ec18e28033ebdedcc3801cb8088b9d41514ae183d0c6ccb67
sha256sums = 8c265f565358e35f26eb7b38c3caa09d551ddb5b0aff18045a9714e6f1829bcc
- sha256sums = f2c27d367f3a14b7c8e16f61bedd74b253cb6c6e27e1ed4201fc23d95740183e
pkgname = radiance
diff --git a/PKGBUILD b/PKGBUILD
index 54b99c700ec2..0f3095c08b51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=radiance
pkgver=0.6.0
-pkgrel=0
+pkgrel=1
pkgdesc='Video art software for live performance'
arch=('x86_64')
url='https://radiance.video'
@@ -11,16 +11,9 @@ depends=('qt5-base' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'fftw' 'libsamplera
makedepends=('cmake')
btrack_pkgver='stable-201810'
source=("https://github.com/zbanks/radiance/archive/${pkgver}.tar.gz"
-"https://github.com/zbanks/BTrack/archive/${btrack_pkgver}.tar.gz"
-'fix-cmake.patch')
-sha256sums=('5b0b780e92f2303d38c447a1efee3ab58ecbb6a106dd54d810945a5d8673ffb0'
-'8c265f565358e35f26eb7b38c3caa09d551ddb5b0aff18045a9714e6f1829bcc'
-'f2c27d367f3a14b7c8e16f61bedd74b253cb6c6e27e1ed4201fc23d95740183e')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/fix-cmake.patch" "CMakeLists.txt"
-}
+"https://github.com/zbanks/BTrack/archive/${btrack_pkgver}.tar.gz")
+sha256sums=('1b4be7cfecff3e8ec18e28033ebdedcc3801cb8088b9d41514ae183d0c6ccb67'
+'8c265f565358e35f26eb7b38c3caa09d551ddb5b0aff18045a9714e6f1829bcc')
build() {
rm -rf "${srcdir}/${pkgname}-${pkgver}/BTrack"
@@ -30,7 +23,7 @@ build() {
mkdir build
cd build
cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DRADIANCE_SYSTEM_RESOURCES=/usr/share/radiance/
- make -j7
+ make
}
package() {
diff --git a/fix-cmake.patch b/fix-cmake.patch
deleted file mode 100644
index 2eba8cc20cbb..000000000000
--- a/fix-cmake.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -130,13 +130,6 @@
- target_link_libraries(libradiance ${radiance_LIBRARIES})
- target_link_libraries(radiance libradiance ${radiance_LIBRARIES})
-
--install(CODE "
-- if(NOT \"${RADIANCE_SYSTEM_RESOURCES}\" STREQUAL \"${CMAKE_INSTALL_PREFIX}/share/${PROJECT_NAME}/\")
-- MESSAGE(\"For an install to work, RADIANCE_SYSTEM_RESOURCES must be set to '\\\${CMAKE_INSTALL_PREFIX}share/${PROJECT_NAME}/'\")
-- MESSAGE(FATAL_ERROR \"Please recompile with cmake -DRADIANCE_SYSTEM_RESOURCES=${CMAKE_INSTALL_PREFIX}/share/${PROJECT_NAME}/\")
-- endif()
--")
--
- INSTALL(TARGETS radiance
- DESTINATION bin
- )