summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvedui2017-09-17 17:06:35 +0200
committerArvedui2017-09-17 17:06:35 +0200
commit500886c85cbac740b45d29a724832bc0ec1754c9 (patch)
tree49b73b999e8685aa78978c519cd6490b8e30effc
downloadaur-500886c85cbac740b45d29a724832bc0ec1754c9.tar.gz
Initial upload: radicale-dovecot-auth-git r1.c7ab5ab-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c835b259133e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Sep 17 15:06:35 UTC 2017
+pkgbase = radicale-dovecot-auth-git
+ pkgdesc = Dovecot auth for radicale
+ pkgver = r1.c7ab5ab
+ pkgrel = 1
+ url = https://github.com/Arvedui/radicale-dovecot-auth
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = radicale
+ options = !emptydirs
+ source = git+https://github.com/Arvedui/radicale-dovecot-auth.git
+ md5sums = SKIP
+
+pkgname = radicale-dovecot-auth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b9b6193bc99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Arvedui <arvedui@posteo.de>
+pkgname=radicale-dovecot-auth-git
+pkgver=r1.c7ab5ab
+pkgrel=1
+pkgdesc="Dovecot auth for radicale"
+arch=("any")
+url="https://github.com/Arvedui/radicale-dovecot-auth"
+license=('GPL')
+groups=()
+depends=('python' 'radicale')
+makedepends=('git')
+options=(!emptydirs)
+source=("git+https://github.com/Arvedui/radicale-dovecot-auth.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd ${srcdir}/radicale-dovecot-auth
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/radicale-dovecot-auth"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: