summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvedui2017-09-17 17:07:03 +0200
committerArvedui2017-09-17 17:07:03 +0200
commitbbb7ba961e643bdbc15dc376bfb910a0743a8f0d (patch)
treecaecc5a29a29940210145bddd1dabffdce1e1c4b
downloadaur-bbb7ba961e643bdbc15dc376bfb910a0743a8f0d.tar.gz
Initial upload: radicale-infcloud-git r20.972757b-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aeec78de2e7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Sep 17 15:07:03 UTC 2017
+pkgbase = radicale-infcloud-git
+ pkgdesc = Infcloud integration for radicale
+ pkgver = r20.972757b
+ pkgrel = 1
+ url = https://github.com/Unrud/RadicaleInfCloud
+ arch = any
+ license = AGPL
+ makedepends = git
+ depends = python
+ depends = radicale
+ options = !emptydirs
+ source = git+https://github.com/Unrud/RadicaleInfCloud
+ md5sums = SKIP
+
+pkgname = radicale-infcloud-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c08ab3824b23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Arvedui <arvedui@posteo.de>
+pkgname=radicale-infcloud-git
+pkgver=r20.972757b
+pkgrel=1
+pkgdesc="Infcloud integration for radicale"
+arch=("any")
+url="https://github.com/Unrud/RadicaleInfCloud"
+license=('AGPL')
+groups=()
+depends=('python' 'radicale')
+makedepends=('git')
+options=(!emptydirs)
+source=("git+https://github.com/Unrud/RadicaleInfCloud")
+md5sums=("SKIP")
+
+pkgver() {
+ cd ${srcdir}/RadicaleInfCloud
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/RadicaleInfCloud"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: