summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Bauer2022-08-24 22:13:06 +0200
committerMichael Bauer2022-08-24 22:13:06 +0200
commitaac7e8f521a58292205d1b3bb7ce106fe598dce7 (patch)
treead840bf83a749c43c1a386882d283ea4e5684407
downloadaur-aac7e8f521a58292205d1b3bb7ce106fe598dce7.tar.gz
initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25a564f7c44b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = radicle-cli
+ pkgdesc = Radicle command line interface
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://app.radicle.xyz/seeds/seed.alt-clients.radicle.xyz/rad:git:hnrkmg77m8tfzj4gi4pa4mbhgysfgzwntjpao/tree
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = libusb
+ depends = gcc-libs
+ depends = openssl
+ source = radicle-cli-0.6.1::git+https://github.com/radicle-dev/radicle-cli.git#commit=1e6ed9b
+ sha512sums = SKIP
+
+pkgname = radicle-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..482cd43ea58f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michael Bauer <michael@m-bauer.org>
+pkgname=radicle-cli
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Radicle command line interface"
+arch=('x86_64')
+url="https://app.radicle.xyz/seeds/seed.alt-clients.radicle.xyz/rad:git:hnrkmg77m8tfzj4gi4pa4mbhgysfgzwntjpao/tree"
+license=('GPL3')
+depends=('libusb' 'gcc-libs' 'openssl')
+makedepends=('git' 'cargo')
+
+_commit=1e6ed9b # tags/v0.6.1 - not available via github repo, missing on radicly.xyz :-(
+# _commit=4ae4174 # tags/0.6.0
+
+source=("$pkgname-$pkgver::git+https://github.com/radicle-dev/radicle-cli.git#commit=${_commit}")
+# TODO: Use radicle.xyz source instead of gituhub when release commit is available there
+# source=("$pkgname-$pkgver::git+https://seed.alt-clients.radicle.xyz/radicle-cli.git#commit=${_commit}")
+
+sha512sums=('SKIP')
+
+package() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo install $pkgname --no-track --locked --root "$pkgdir/usr/" --path .
+}