summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Arias Orzanco2023-10-16 20:31:44 +0200
committerAntonio Arias Orzanco2023-10-16 20:31:44 +0200
commit87f1640f04e1b707ca7889db2cfe1c715a910344 (patch)
tree3aa46fe160068ea7c31f3dcf74a8449e8dacfb89
parentd9a4e272392ccf92656cae02adb75063d8dca505 (diff)
downloadaur-87f1640f04e1b707ca7889db2cfe1c715a910344.tar.gz
Creating initial aur package.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD19
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e83348ad76e..5cab81ff2fd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
-pkgbase = python-pyradios
- pkgdesc = Python client for the Radio Browser API.
- pkgver = 1.0.2
+pkgbase = radioactive
+ pkgdesc = Play and record any radio stations around the globe right from your terminal.
+ pkgver = 2.8.0
pkgrel = 1
- url = https://github.com/andreztz/pyradios
+ url = https://github.com/deep5050/radio-active
arch = any
- license = GPL3
+ license = MIT
makedepends = python-setuptools
- depends = python
- source = python-pyradios-1.0.2.tar.gz::https://github.com/andreztz/pyradios/archive/refs/tags/v1.0.2.tar.gz
- md5sums = ed512d3607f29b5568534b12e1d2035c
+ depends = ffmpeg
+ depends = python-colorlog
+ depends = python-pick
+ depends = python-pyradios=1.0.2
+ depends = python-requests-cache
+ depends = python-rich
+ depends = python-zenlog
+ source = radioactive-2.8.0.tar.gz::https://github.com/deep5050/radio-active/archive/refs/tags/v2.8.0.tar.gz
+ md5sums = 3bd338dd40a91f299ad5877b06176fbd
-pkgname = python-pyradios
+pkgname = radioactive
diff --git a/PKGBUILD b/PKGBUILD
index cf33b41d2a17..7e8570136ee4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Antonio Arias Orzanco <antonio dot arias99999 at gmail dot com>
-_name=pyradios
-pkgname=python-$_name
-pkgver=1.0.2
+_name=radio-active
+pkgname=radioactive
+pkgver=2.8.0
pkgrel=1
-pkgdesc="Python client for the Radio Browser API."
+pkgdesc="Play and record any radio stations around the globe right from your terminal."
arch=('any')
-url="https://github.com/andreztz/pyradios"
-license=('GPL3')
-depends=('python')
+url="https://github.com/deep5050/radio-active"
+license=('MIT')
+depends=('ffmpeg' 'python-colorlog' 'python-pick' 'python-pyradios=1.0.2' 'python-requests-cache' 'python-rich' 'python-zenlog')
makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/andreztz/pyradios/archive/refs/tags/v$pkgver.tar.gz")
-md5sums=('ed512d3607f29b5568534b12e1d2035c')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/deep5050/radio-active/archive/refs/tags/v$pkgver.tar.gz")
+md5sums=('3bd338dd40a91f299ad5877b06176fbd')
build() {
cd "$_name-$pkgver"
@@ -21,6 +21,5 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --skip-build --optimize=1
- rm -rf $pkgdir/usr/lib/python3.11/site-packages/tests
}