summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Arias Orzanco2023-12-17 16:40:07 +0100
committerAntonio Arias Orzanco2023-12-17 16:40:07 +0100
commitfcbe10705ed18d504b81a925f551cb328c89171c (patch)
tree87c3db113c5fead7da538259fc102bdc712a96b9
parent235f99d4e24e83760e92159a83107e4cab228a5d (diff)
downloadaur-fcbe10705ed18d504b81a925f551cb328c89171c.tar.gz
Modern python build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e2dca30330f..587029cfedd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = radioactive
pkgdesc = Play and record any radio stations around the globe right from your terminal.
pkgver = 2.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/deep5050/radio-active
arch = any
license = MIT
@@ -10,11 +10,10 @@ pkgbase = radioactive
depends = python-colorlog
depends = python-pick
depends = python-psutil
- depends = python-pyradios>=1.0.2
+ depends = python-pyradios=1.0.2
depends = python-requests-cache
depends = python-rich
depends = python-zenlog
- conflicts = radio-active
source = radioactive-2.9.0.tar.gz::https://github.com/deep5050/radio-active/archive/refs/tags/v2.9.0.tar.gz
md5sums = 7a9a7710f094e9019d8d6f960ffa5e38
diff --git a/PKGBUILD b/PKGBUILD
index ac262cf203c3..e8135f3524ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,26 @@
_name=radio-active
pkgname=radioactive
pkgver=2.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Play and record any radio stations around the globe right from your terminal."
arch=('any')
url="https://github.com/deep5050/radio-active"
license=('MIT')
-depends=('ffmpeg' 'python-colorlog' 'python-pick' 'python-psutil' 'python-pyradios>=1.0.2' 'python-requests-cache' 'python-rich' 'python-zenlog')
+depends=('ffmpeg' 'python-colorlog' 'python-pick' 'python-psutil' 'python-pyradios=1.0.2' 'python-requests-cache' 'python-rich' 'python-zenlog')
makedepends=('python-setuptools')
-conflicts=('radio-active')
+cpnflicts=("radio-active")
source=("$pkgname-$pkgver.tar.gz::https://github.com/deep5050/radio-active/archive/refs/tags/v$pkgver.tar.gz")
md5sums=('7a9a7710f094e9019d8d6f960ffa5e38')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ #python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ #python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}