summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorknedlyk2015-06-23 23:29:27 +0200
committerknedlyk2015-06-23 23:29:27 +0200
commit5434e785e3acbd00e81ff122f94d15bdbe19ecb5 (patch)
tree608a7883d084dbb8742b0ea3247ae439e9acbad8
downloadaur-5434e785e3acbd00e81ff122f94d15bdbe19ecb5.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD31
-rw-r--r--encoding.patch17
-rw-r--r--gtk.patch12
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..579de60e0799
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = radiotray
+ pkgdesc = An online radio streaming player that runs on a Linux system tray.
+ pkgver = 0.7.3
+ pkgrel = 7
+ url = http://radiotray.wordpress.com/
+ arch = any
+ license = GPL
+ makedepends = python2
+ depends = gstreamer0.10-base-plugins
+ depends = gstreamer0.10-python
+ depends = pygtk
+ depends = python2-notify
+ depends = python2-xdg
+ depends = python2-dbus
+ depends = gstreamer0.10-good-plugins
+ depends = python2-gobject
+ depends = python2-lxml
+ depends = libappindicator-gtk2
+ optdepends = gstreamer0.10-bad-plugins
+ optdepends = gstreamer0.10-ugly-plugins
+ optdepends = gstreamer0.10-ffmpeg
+ provides = radiotray
+ conflicts = radiotray-hg
+ source = https://bitbucket.org/carlmig/radio-tray/get/radiotray-0.7.3.tar.gz
+ source = encoding.patch
+ source = gtk.patch
+ md5sums = 33d30ba8d2a293382f60990b761d1d38
+ md5sums = 3f3fe97dfe4fef65af8345d24fd19a2e
+ md5sums = 0ef80483af7a7a627e5d1dbef978d6fc
+
+pkgname = radiotray
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6369ea523ec2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Yarema aka Knedlyk <yupadmin@gmail.com>
+
+pkgname=radiotray
+pkgver=0.7.3
+pkgrel=7
+commit=1717a0e8c143
+pkgdesc="An online radio streaming player that runs on a Linux system tray."
+arch=(any)
+url="http://radiotray.wordpress.com/"
+license=(GPL)
+depends=('gstreamer0.10-base-plugins' 'gstreamer0.10-python' 'pygtk' \
+'python2-notify' 'python2-xdg' 'python2-dbus' 'gstreamer0.10-good-plugins' \
+'python2-gobject' 'python2-lxml' 'libappindicator-gtk2')
+optdepends=('gstreamer0.10-bad-plugins' 'gstreamer0.10-ugly-plugins' 'gstreamer0.10-ffmpeg')
+makedepends=(python2)
+provides=(radiotray)
+source=(https://bitbucket.org/carlmig/radio-tray/get/${pkgname}-${pkgver}.tar.gz
+ encoding.patch
+ gtk.patch)
+conflicts=(radiotray-hg)
+package() {
+ cd $srcdir/carlmig-radio-tray-$commit
+ patch -p1 < $srcdir/encoding.patch || return 1
+ patch -p1 < $srcdir/gtk.patch || return 1
+ mkdir $pkgdir/usr
+ python2 setup.py install --root=${pkgdir}/ --optimize=1 || return 1
+ chmod +x $pkgdir/usr/bin/radiotray || return 1
+}
+md5sums=('33d30ba8d2a293382f60990b761d1d38'
+ '3f3fe97dfe4fef65af8345d24fd19a2e'
+ '0ef80483af7a7a627e5d1dbef978d6fc')
diff --git a/encoding.patch b/encoding.patch
new file mode 100644
index 000000000000..0e2510187a93
--- /dev/null
+++ b/encoding.patch
@@ -0,0 +1,17 @@
+diff -Naur radiotray-0.7.3/src/Context.py radiotray-0.7.3-new/src/Context.py
+--- radiotray-0.7.3/src/Context.py 2012-04-02 23:54:38.000000000 +0200
++++ radiotray-0.7.3-new/src/Context.py 2013-09-07 12:14:32.000000000 +0200
+@@ -40,9 +40,9 @@
+ if(self.title and len(self.title) > 0 and self.artist and len(self.artist) > 0):
+ return self.artist + " - " + self.title
+ elif(self.title and len(self.title) > 0):
+- return self.title
++ return self.title.encode('latin-1').decode('cp1251').encode('utf8')
+ elif(self.artist and len(self.artist) > 0):
+- return self.artist
++ return self.artist.encode('latin-1').decode('cp1251').encode('utf8')
+ else:
+ return 'Playing'
+-
+\ No newline at end of file
++
diff --git a/gtk.patch b/gtk.patch
new file mode 100644
index 000000000000..ea71f01f05cc
--- /dev/null
+++ b/gtk.patch
@@ -0,0 +1,12 @@
+diff -rupN carlmig-radio-tray-1717a0e8c143/src/SysTray.py patched/src/SysTray.py
+--- carlmig-radio-tray-1717a0e8c143/src/SysTray.py 2012-08-09 23:23:51.000000000 +0200
++++ patched/src/SysTray.py 2015-01-05 13:34:09.941743473 +0100
+@@ -182,7 +182,7 @@ class SysTray(object):
+
+
+ def run(self):
+- gtk.gdk.threads_init()
++# gtk.gdk.threads_init()
+ gtk.main()
+
+