summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-03-17 20:38:35 +0000
committerJonathon Fernyhough2021-03-17 20:39:12 +0000
commit6f06e1933655766f688d91e3c2a814add4a7a534 (patch)
tree545862f2619b294fdeee3653b04becf6796b1c92
parentbc04c0e6248927a0da04cad9be8c08cee25804a0 (diff)
downloadaur-6f06e1933655766f688d91e3c2a814add4a7a534.tar.gz
Tweak package(). Doesn't help with removal of python2.
-rw-r--r--PKGBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55251e904a04..e6e006fc7dff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="An online radio streaming player that runs on a Linux system tray."
arch=(any)
url="https://radiotray.wordpress.com/"
license=(GPL)
-depends=('gstreamer' 'gst-plugins-base' 'gst-plugins-good' \
+depends=('gstreamer' 'gst-plugins-base' 'gst-plugins-good'
'python2-dbus' 'python2-gobject' 'python2-lxml' 'python2-notify' 'python2-xdg')
optdepends=('gst-plugins-bad: extra codec support'
'gst-plugins-ugly: extra codec support'
@@ -38,14 +38,7 @@ prepare() {
patch -Np1 < "${srcdir}/reduce-logging.patch"
}
-build() {
- cd $pkgname-$pkgver
- python2 setup.py bdist
-}
-
package() {
cd $pkgname-$pkgver
- bsdtar pxf "dist/${pkgname}-${pkgver}.linux-${CARCH}.tar.gz" -C "${pkgdir}"
- chown -R root: "${pkgdir}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
}
-