summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-03-18 11:59:05 +0000
committerJonathon Fernyhough2021-03-18 11:59:05 +0000
commit7ba41d4e3c482641974eb9a371a35e2149db49af (patch)
treee6a3bad0fed4ce5b1d779dac9cc7a0c7a29321c0
parent6f06e1933655766f688d91e3c2a814add4a7a534 (diff)
downloadaur-7ba41d4e3c482641974eb9a371a35e2149db49af.tar.gz
Switch source to Python3 fork
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD44
2 files changed, 28 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb8cde41c238..1c0a26df8b63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,24 @@
pkgbase = radiotray
pkgdesc = An online radio streaming player that runs on a Linux system tray.
pkgver = 0.7.3
- pkgrel = 14
+ pkgrel = 15
url = https://radiotray.wordpress.com/
arch = any
license = GPL
depends = gstreamer
depends = gst-plugins-base
depends = gst-plugins-good
- depends = python2-dbus
- depends = python2-gobject
- depends = python2-lxml
- depends = python2-notify
- depends = python2-xdg
+ depends = dbus-python
+ depends = python-gobject
+ depends = python-lxml
+ depends = python-notify2
+ depends = python-xdg
optdepends = gst-plugins-bad: extra codec support
optdepends = gst-plugins-ugly: extra codec support
optdepends = gst-libav: nonfree media decoding
optdepends = libappindicator-gtk3: indicator applet support
- source = radiotray-0.7.3.tar.gz::https://sourceforge.net/projects/radiotray/files/releases/radiotray-0.7.3.tar.gz/download/
- source = encoding.patch
- source = 02_compatibility_glib-2.41.patch
- source = 03_upstream_repo.patch
- source = 04_gtk3_issues.patch
- source = reduce-logging.patch
- sha256sums = 709cbabbd03627270f60cd56084803d6f03fe0e14fbfc15b6325b4c5bd9faf2d
- sha256sums = a73badc0ddbf726d3f554e328b8836883bf816751cd0dc2034795a03466cd2df
- sha256sums = b6d1d7fe74be1ec2ecad653262111f509d6fd60b8e666eb5e15d7bcb21e7a58b
- sha256sums = 04748958923e3c2cac8944700a0786d066ab17d8284155adf316adab78dd0c55
- sha256sums = c67845683a6d7d63eb26bbefe3c06921e0e6cbc2a5cb32c58b47377fdeb83644
- sha256sums = 231ec3fb848069cf909f704e0e129fd649a9f8955178fe5407c7457d94ab0663
+ source = git+https://github.com/lubosz/radiotray.git#commit=0303ad6017a9a81caa71d046ef270ba6ebefed39
+ b2sums = SKIP
pkgname = radiotray
diff --git a/PKGBUILD b/PKGBUILD
index e6e006fc7dff..21bb1886e21f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,41 +4,37 @@
pkgname=radiotray
pkgver=0.7.3
-pkgrel=14
+pkgrel=15
pkgdesc="An online radio streaming player that runs on a Linux system tray."
arch=(any)
url="https://radiotray.wordpress.com/"
license=(GPL)
depends=('gstreamer' 'gst-plugins-base' 'gst-plugins-good'
- 'python2-dbus' 'python2-gobject' 'python2-lxml' 'python2-notify' 'python2-xdg')
+ 'dbus-python' 'python-gobject' 'python-lxml' 'python-notify2' 'python-xdg')
optdepends=('gst-plugins-bad: extra codec support'
'gst-plugins-ugly: extra codec support'
'gst-libav: nonfree media decoding'
'libappindicator-gtk3: indicator applet support')
-source=("${pkgname}-${pkgver}.tar.gz::https://sourceforge.net/projects/radiotray/files/releases/${pkgname}-${pkgver}.tar.gz/download/"
- "encoding.patch"
- "02_compatibility_glib-2.41.patch"
- "03_upstream_repo.patch"
- "04_gtk3_issues.patch"
- "reduce-logging.patch")
+#source=("${pkgname}-${pkgver}.tar.gz::https://sourceforge.net/projects/radiotray/files/releases/${pkgname}-${pkgver}.tar.gz/download/"
+# "encoding.patch"
+# "02_compatibility_glib-2.41.patch"
+# "03_upstream_repo.patch"
+# "04_gtk3_issues.patch"
+# "reduce-logging.patch")
+source=(git+https://github.com/lubosz/radiotray.git#commit=0303ad6017a9a81caa71d046ef270ba6ebefed39)
-sha256sums=('709cbabbd03627270f60cd56084803d6f03fe0e14fbfc15b6325b4c5bd9faf2d'
- 'a73badc0ddbf726d3f554e328b8836883bf816751cd0dc2034795a03466cd2df'
- 'b6d1d7fe74be1ec2ecad653262111f509d6fd60b8e666eb5e15d7bcb21e7a58b'
- '04748958923e3c2cac8944700a0786d066ab17d8284155adf316adab78dd0c55'
- 'c67845683a6d7d63eb26bbefe3c06921e0e6cbc2a5cb32c58b47377fdeb83644'
- '231ec3fb848069cf909f704e0e129fd649a9f8955178fe5407c7457d94ab0663')
+b2sums=('SKIP')
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 < "${srcdir}/encoding.patch"
- patch -Np1 < "${srcdir}/02_compatibility_glib-2.41.patch"
- patch -Np1 < "${srcdir}/03_upstream_repo.patch"
- patch -Np1 < "${srcdir}/04_gtk3_issues.patch"
- patch -Np1 < "${srcdir}/reduce-logging.patch"
-}
+#prepare() {
+# cd $pkgname-$pkgver
+# patch -Np1 < "${srcdir}/encoding.patch"
+# patch -Np1 < "${srcdir}/02_compatibility_glib-2.41.patch"
+# patch -Np1 < "${srcdir}/03_upstream_repo.patch"
+# patch -Np1 < "${srcdir}/04_gtk3_issues.patch"
+# patch -Np1 < "${srcdir}/reduce-logging.patch"
+#}
package() {
- cd $pkgname-$pkgver
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd $pkgname
+ python setup.py install --root="$pkgdir" --optimize=1
}