summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-07-09 13:27:30 +0100
committerJonathon Fernyhough2017-07-09 13:28:00 +0100
commitb8285b1016117d0ed9b53973ed6b9d65838c6824 (patch)
treef51d5db5599278a46a70586e2a35432b6e03f105
parent3c9c7800ce3f679629c4bcb7ad9e9ce4e1eabba3 (diff)
downloadaur-b8285b1016117d0ed9b53973ed6b9d65838c6824.tar.gz
Patch to reduce default log level
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--reduce-logging.patch13
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 549f932d159e..e4792ae08904 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = radiotray
pkgdesc = An online radio streaming player that runs on a Linux system tray.
pkgver = 0.7.3
- pkgrel = 10
+ pkgrel = 11
url = https://radiotray.wordpress.com/
arch = any
license = GPL
@@ -27,11 +27,13 @@ pkgbase = radiotray
source = 02_compatibility_glib-2.41.patch
source = 03_upstream_repo.patch
source = 04_gtk3_issues.patch
+ source = reduce-logging.patch
sha256sums = 464c555b8d9278e918d3718f81a1c0cfa7d9a54018d1a2f6b04b33dc40ea825c
sha256sums = a73badc0ddbf726d3f554e328b8836883bf816751cd0dc2034795a03466cd2df
sha256sums = b6d1d7fe74be1ec2ecad653262111f509d6fd60b8e666eb5e15d7bcb21e7a58b
sha256sums = 04748958923e3c2cac8944700a0786d066ab17d8284155adf316adab78dd0c55
sha256sums = c67845683a6d7d63eb26bbefe3c06921e0e6cbc2a5cb32c58b47377fdeb83644
+ sha256sums = 231ec3fb848069cf909f704e0e129fd649a9f8955178fe5407c7457d94ab0663
pkgname = radiotray
diff --git a/PKGBUILD b/PKGBUILD
index dca1fdbc2b2b..6134dd89df5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=radiotray
pkgver=0.7.3
-pkgrel=10
+pkgrel=11
_commit=1717a0e8c143
pkgdesc="An online radio streaming player that runs on a Linux system tray."
arch=(any)
@@ -20,14 +20,16 @@ source=("${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/carlmig/radio-tray/g
"encoding.patch"
"02_compatibility_glib-2.41.patch"
"03_upstream_repo.patch"
- "04_gtk3_issues.patch")
+ "04_gtk3_issues.patch"
+ "reduce-logging.patch")
conflicts=(radiotray-hg radiotray-python3-git)
sha256sums=('464c555b8d9278e918d3718f81a1c0cfa7d9a54018d1a2f6b04b33dc40ea825c'
'a73badc0ddbf726d3f554e328b8836883bf816751cd0dc2034795a03466cd2df'
'b6d1d7fe74be1ec2ecad653262111f509d6fd60b8e666eb5e15d7bcb21e7a58b'
'04748958923e3c2cac8944700a0786d066ab17d8284155adf316adab78dd0c55'
- 'c67845683a6d7d63eb26bbefe3c06921e0e6cbc2a5cb32c58b47377fdeb83644')
+ 'c67845683a6d7d63eb26bbefe3c06921e0e6cbc2a5cb32c58b47377fdeb83644'
+ '231ec3fb848069cf909f704e0e129fd649a9f8955178fe5407c7457d94ab0663')
prepare() {
cd "${srcdir}/carlmig-radio-tray-${_commit}"
@@ -35,6 +37,7 @@ prepare() {
patch -p1 < "${srcdir}/02_compatibility_glib-2.41.patch"
patch -p1 < "${srcdir}/03_upstream_repo.patch"
patch -p1 < "${srcdir}/04_gtk3_issues.patch"
+ patch -p1 < "${srcdir}/reduce-logging.patch"
}
build() {
diff --git a/reduce-logging.patch b/reduce-logging.patch
new file mode 100644
index 000000000000..f2b9ee2c383d
--- /dev/null
+++ b/reduce-logging.patch
@@ -0,0 +1,13 @@
+diff --git a/src/RadioTray.py b/src/RadioTray.py
+index cc6eec2..77f738a 100644
+--- a/src/RadioTray.py
++++ b/src/RadioTray.py
+@@ -167,7 +167,7 @@ class RadioTray(object):
+ def configLogging(self):
+ # config logging
+ self.logger = logging.getLogger('radiotray')
+- self.logger.setLevel(logging.DEBUG)
++ self.logger.setLevel(logging.WARN)
+ handler = logging.handlers.RotatingFileHandler(LOGFILE, maxBytes=2000000, backupCount=1)
+ formatter = logging.Formatter('%(asctime)s - %(levelname)s - %(message)s')
+ handler.setFormatter(formatter)