summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorknedlyk2015-06-23 23:29:41 +0200
committerknedlyk2015-06-23 23:29:41 +0200
commit2f831acf6be71bbc3fd553f587670a50718f692f (patch)
treee29439e0a3931990ab2fb7f3d3479cc11c9449aa
downloadaur-2f831acf6be71bbc3fd553f587670a50718f692f.tar.gz
Initial import
-rw-r--r--.AURINFO28
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD48
-rw-r--r--encoding.patch17
4 files changed, 123 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..9726eaf2b4c6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,28 @@
+pkgbase = radiotray-hg
+ pkgdesc = An online radio streaming player that runs on a Linux system tray.
+ pkgver = 495
+ pkgrel = 1
+ url = http://radiotray.wordpress.com/
+ arch = any
+ license = GPL
+ makedepends = mercurial
+ depends = gstreamer0.10-base-plugins
+ depends = gstreamer0.10-python
+ depends = pygtk
+ depends = python2-notify
+ depends = python2-xdg
+ depends = python2-dbus
+ depends = gstreamer0.10-good-plugins
+ depends = python2-gobject
+ depends = python2-lxml
+ optdepends = gstreamer0.10-bad-plugins
+ optdepends = gstreamer0.10-ugly-plugins
+ optdepends = gstreamer0.10-ffmpeg
+ provides = radiotray
+ conflicts = radiotray
+ conflicts = radiotray-svn
+ source = radiotray::hg+https://bitbucket.org/carlmig/radio-tray#revision=40d9969
+ source = encoding.patch
+
+pkgname = radiotray-hg
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60a228de923b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = radiotray-hg
+ pkgdesc = An online radio streaming player that runs on a Linux system tray.
+ pkgver = 495
+ pkgrel = 1
+ url = http://radiotray.wordpress.com/
+ arch = any
+ license = GPL
+ makedepends = mercurial
+ depends = gstreamer0.10-base-plugins
+ depends = gstreamer0.10-python
+ depends = pygtk
+ depends = python2-notify
+ depends = python2-xdg
+ depends = python2-dbus
+ depends = gstreamer0.10-good-plugins
+ depends = python2-gobject
+ depends = python2-lxml
+ optdepends = gstreamer0.10-bad-plugins
+ optdepends = gstreamer0.10-ugly-plugins
+ optdepends = gstreamer0.10-ffmpeg
+ provides = radiotray
+ conflicts = radiotray
+ conflicts = radiotray-svn
+ source = radiotray::hg+https://bitbucket.org/carlmig/radio-tray#revision=40d9969
+ source = encoding.patch
+ md5sums = SKIP
+ md5sums = 4c6862df37e0fcb304d9f0b801f85332
+
+pkgname = radiotray-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49179c54bcb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: Yarema aka Knedlyk <yupadmin@gmail.com>
+_pkgname=radiotray
+pkgname=${_pkgname}-hg
+pkgver=495
+pkgrel=1
+pkgdesc="An online radio streaming player that runs on a Linux system tray."
+arch=(any)
+url="http://radiotray.wordpress.com/"
+license=(GPL)
+depends=('gstreamer0.10-base-plugins' 'gstreamer0.10-python' 'pygtk' \
+'python2-notify' 'python2-xdg' 'python2-dbus' 'gstreamer0.10-good-plugins' \
+'python2-gobject' 'python2-lxml')
+optdepends=('gstreamer0.10-bad-plugins' 'gstreamer0.10-ugly-plugins' 'gstreamer0.10-ffmpeg')
+source=('radiotray::hg+https://bitbucket.org/carlmig/radio-tray#revision=40d9969'
+ encoding.patch)
+makedepends=('mercurial')
+provides=(radiotray)
+conflicts=('radiotray' 'radiotray-svn')
+
+#rev=1717a0e
+rev=a071fa7
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ #echo $(hg identify -n).$(hg identify -i)
+ # In mercurial, you cannot assure that id -n is equal in two copies
+ # of the same repository!!!!! So let's try this and hope for the best.
+# echo $(hg id -n).$(hg id -i)
+ echo $(hg id -n)
+}
+
+
+build() {
+ cd $srcdir/${_pkgname}/src
+ patch -p4 < $srcdir/encoding.patch
+}
+
+package() {
+
+ cd $srcdir/${_pkgname}
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+
+ chmod +x $pkgdir/usr/bin/radiotray
+ find $pkgdir -perm 600 -exec chmod 644 {} \;
+}
+
+md5sums=('SKIP'
+ '4c6862df37e0fcb304d9f0b801f85332')
diff --git a/encoding.patch b/encoding.patch
new file mode 100644
index 000000000000..9fa588b0b065
--- /dev/null
+++ b/encoding.patch
@@ -0,0 +1,17 @@
+diff -Naur radiotray-0.7.3/build/lib/radiotray/Context.py radiotray-0.7.3-new/build/lib/radiotray/Context.py
+--- radiotray-0.7.3/build/lib/radiotray/Context.py 2012-04-02 23:54:38.000000000 +0200
++++ radiotray-0.7.3-new/build/lib/radiotray/Context.py 2013-09-07 12:14:32.000000000 +0200
+@@ -40,9 +40,9 @@
+ if(self.title and len(self.title) > 0 and self.artist and len(self.artist) > 0):
+ return self.artist + " - " + self.title
+ elif(self.title and len(self.title) > 0):
+- return self.title
++ return self.title.encode('latin-1').decode('cp1251').encode('utf8')
+ elif(self.artist and len(self.artist) > 0):
+- return self.artist
++ return self.artist.encode('latin-1').decode('cp1251').encode('utf8')
+ else:
+ return 'Playing'
+-
+\ No newline at end of file
++