summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-12-04 20:20:33 -0500
committerTed Alff2017-12-04 20:20:33 -0500
commit8850cc6d3a695cf98ad210c57f41675c7f5c1fc4 (patch)
treee8b5aa424dcd7d4fbd514e3484b20f78c6cfd66b
parent0458a3d07e4865a3cca1659b3727c0345d0045ea (diff)
downloadaur-8850cc6d3a695cf98ad210c57f41675c7f5c1fc4.tar.gz
Add patch so compilation does not fail on jsoncpp deprecated symbols.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--no_fail_on_warning.patch12
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1d2a4657779..5c145a7062b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Oct 8 12:42:06 UTC 2017
+# Tue Dec 5 01:20:09 UTC 2017
pkgbase = radiotray-ng
pkgdesc = An Internet radio player for Linux
pkgver = 0.1.8
@@ -23,7 +23,9 @@ pkgbase = radiotray-ng
optdepends = python2-lxml: Convert radiotray bookmarks to radiotray-ng format
options = !libtool
source = radiotray-ng.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v0.1.8.tar.gz
+ source = no_fail_on_warning.patch
sha256sums = 4b8496256d28c7754b46cee28481bf857bb17df3fc781e014f056b2282f76fc6
+ sha256sums = cedd72d28535e202ca8658d6fbe96d7c1e18a079ecf8810bf79c8a7c09716baf
pkgname = radiotray-ng
diff --git a/PKGBUILD b/PKGBUILD
index 814a67431620..4e3c9a1e7f5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,13 +12,16 @@ depends=('boost-libs' 'curl' 'gstreamer' 'jsoncpp' 'libappindicator-gtk3'
makedepends=('cmake' 'boost' 'lsb-release')
optdepends=('python2-lxml: Convert radiotray bookmarks to radiotray-ng format')
options=('!libtool')
-source=("${pkgname}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz")
-sha256sums=('4b8496256d28c7754b46cee28481bf857bb17df3fc781e014f056b2282f76fc6')
+source=("${pkgname}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz"
+ 'no_fail_on_warning.patch')
+sha256sums=('4b8496256d28c7754b46cee28481bf857bb17df3fc781e014f056b2282f76fc6'
+ 'cedd72d28535e202ca8658d6fbe96d7c1e18a079ecf8810bf79c8a7c09716baf')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
# Build fails when GMock is found, so don't check for it, don't compile tests
sed -i 's:if (GMOCK_FOUND):if (GMOCK_FOUND AND ENABLE_GMOCK):' CMakeLists.txt
+ patch -uNp2 -r- -i ../no_fail_on_warning.patch
}
build() {
diff --git a/no_fail_on_warning.patch b/no_fail_on_warning.patch
new file mode 100644
index 000000000000..17c9234472d7
--- /dev/null
+++ b/no_fail_on_warning.patch
@@ -0,0 +1,12 @@
+diff -Naur ./radiotray-ng.orig/CMakeLists.txt ./radiotray-ng/CMakeLists.txt
+--- ./radiotray-ng.orig/CMakeLists.txt 2017-12-01 20:37:18.786630180 -0500
++++ ./radiotray-ng/CMakeLists.txt 2017-12-01 20:37:44.756629724 -0500
+@@ -51,7 +51,7 @@
+ set(CMAKE_CXX_STANDARD 14)
+ add_definitions("-DBOOST_LOG_DYN_LINK")
+ add_compile_options("-fdiagnostics-color=auto")
+-set(warnings "-Wall -Wextra -Werror")
++set(warnings "-Wall -Wextra")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -s")
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -s")
+