summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2018-01-04 22:13:22 -0500
committerTed Alff2018-01-04 22:13:22 -0500
commit9eb31d3a3acaedfa9cfac27916dce214eaae86d1 (patch)
treec68faeca6e4cf9ca947f5f70dd630684cdeea868
parent8850cc6d3a695cf98ad210c57f41675c7f5c1fc4 (diff)
downloadaur-9eb31d3a3acaedfa9cfac27916dce214eaae86d1.tar.gz
Version bump 0.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--no_fail_on_warning.patch12
3 files changed, 11 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c145a7062b3..6abea923bb7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 5 01:20:09 UTC 2017
+# Fri Jan 5 03:10:41 UTC 2018
pkgbase = radiotray-ng
pkgdesc = An Internet radio player for Linux
- pkgver = 0.1.8
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/ebruck/radiotray-ng
arch = i686
@@ -20,12 +20,11 @@ pkgbase = radiotray-ng
depends = libnotify
depends = libxdg-basedir
depends = glibmm
+ depends = wxgtk3
optdepends = python2-lxml: Convert radiotray bookmarks to radiotray-ng format
options = !libtool
- source = radiotray-ng.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v0.1.8.tar.gz
- source = no_fail_on_warning.patch
- sha256sums = 4b8496256d28c7754b46cee28481bf857bb17df3fc781e014f056b2282f76fc6
- sha256sums = cedd72d28535e202ca8658d6fbe96d7c1e18a079ecf8810bf79c8a7c09716baf
+ source = radiotray-ng-0.2.0.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v0.2.0.tar.gz
+ sha256sums = 1965e5dc0853349c3141ac843f640587fb1e0edf50a44be23da783adfe98a0d5
pkgname = radiotray-ng
diff --git a/PKGBUILD b/PKGBUILD
index 4e3c9a1e7f5f..f383da62f8a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=radiotray-ng
-pkgver=0.1.8
+pkgver=0.2.0
pkgrel=1
pkgdesc="An Internet radio player for Linux"
arch=('i686' 'x86_64')
url="https://github.com/ebruck/radiotray-ng"
license=('GPL')
depends=('boost-libs' 'curl' 'gstreamer' 'jsoncpp' 'libappindicator-gtk3'
- 'libbsd' 'libnotify' 'libxdg-basedir' 'glibmm')
+ 'libbsd' 'libnotify' 'libxdg-basedir' 'glibmm' 'wxgtk3')
makedepends=('cmake' 'boost' 'lsb-release')
optdepends=('python2-lxml: Convert radiotray bookmarks to radiotray-ng format')
options=('!libtool')
-source=("${pkgname}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz"
- 'no_fail_on_warning.patch')
-sha256sums=('4b8496256d28c7754b46cee28481bf857bb17df3fc781e014f056b2282f76fc6'
- 'cedd72d28535e202ca8658d6fbe96d7c1e18a079ecf8810bf79c8a7c09716baf')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz")
+sha256sums=('1965e5dc0853349c3141ac843f640587fb1e0edf50a44be23da783adfe98a0d5')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
# Build fails when GMock is found, so don't check for it, don't compile tests
sed -i 's:if (GMOCK_FOUND):if (GMOCK_FOUND AND ENABLE_GMOCK):' CMakeLists.txt
- patch -uNp2 -r- -i ../no_fail_on_warning.patch
}
build() {
@@ -30,7 +27,8 @@ build() {
mkdir build
cd build
- cmake .. -DCMAKE_BUILD_TYPE=Release
+ cmake .. -DCMAKE_BUILD_TYPE=Release \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3
make
}
diff --git a/no_fail_on_warning.patch b/no_fail_on_warning.patch
deleted file mode 100644
index 17c9234472d7..000000000000
--- a/no_fail_on_warning.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur ./radiotray-ng.orig/CMakeLists.txt ./radiotray-ng/CMakeLists.txt
---- ./radiotray-ng.orig/CMakeLists.txt 2017-12-01 20:37:18.786630180 -0500
-+++ ./radiotray-ng/CMakeLists.txt 2017-12-01 20:37:44.756629724 -0500
-@@ -51,7 +51,7 @@
- set(CMAKE_CXX_STANDARD 14)
- add_definitions("-DBOOST_LOG_DYN_LINK")
- add_compile_options("-fdiagnostics-color=auto")
--set(warnings "-Wall -Wextra -Werror")
-+set(warnings "-Wall -Wextra")
- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -s")
- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -s")
-