summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-10-11 21:28:01 -0400
committerTed Alff2017-10-11 21:28:01 -0400
commit7fa6be07aef9fdd468381ec49104bc6d9da42b0d (patch)
treec2837dca6ab1b0cf976ad874f72b3b6b29436759
parentdfe56692e36c7a394d9e84517481171173dc710d (diff)
downloadaur-7fa6be07aef9fdd468381ec49104bc6d9da42b0d.tar.gz
Change branch to v0.2.0-dev
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--remove_GMock_check.patch24
3 files changed, 9 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b5aa841bd08..0d28a50ec710 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Sep 27 00:55:29 UTC 2017
+# Thu Oct 12 01:27:03 UTC 2017
pkgbase = radiotray-ng-git
pkgdesc = An Internet radio player for Linux
- pkgver = 0.1.8.r27.8e772f7
+ pkgver = 0.2.0.r20.d5d7f9c
pkgrel = 1
url = https://github.com/ebruck/radiotray-ng
arch = i686
@@ -22,13 +22,11 @@ pkgbase = radiotray-ng-git
depends = libxdg-basedir
depends = glibmm
optdepends = python2-lxml: Convert radiotray bookmarks to radiotray-ng format
- provides = radiotray-ng=0.1.8
+ provides = radiotray-ng=0.2.0
conflicts = radiotray-ng
options = !libtool
- source = radiotray-ng::git+https://github.com/ebruck/radiotray-ng#branch=v0.1.8-dev
- source = remove_GMock_check.patch
+ source = radiotray-ng::git+https://github.com/ebruck/radiotray-ng#branch=v0.2.0-dev
sha256sums = SKIP
- sha256sums = d2af2f79007ddf2aad38b9531d0adc69859632a14a562983f5be3dcec973df02
pkgname = radiotray-ng-git
diff --git a/PKGBUILD b/PKGBUILD
index 4658c15e75d6..86405f30294e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=radiotray-ng
pkgname=${_pkgname}-git
-_pkgver=0.1.8
+_pkgver=0.2.0
_branch=v${_pkgver}-dev
-pkgver=0.1.8.r27.8e772f7
+pkgver=0.2.0.r20.d5d7f9c
pkgrel=1
pkgdesc="An Internet radio player for Linux"
arch=('i686' 'x86_64')
@@ -17,10 +17,8 @@ optdepends=('python2-lxml: Convert radiotray bookmarks to radiotray-ng format')
options=('!libtool')
provides=("${_pkgname}=${pkgver%\.r*}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/ebruck/radiotray-ng#branch=${_branch}"
- 'remove_GMock_check.patch')
-sha256sums=('SKIP'
- 'd2af2f79007ddf2aad38b9531d0adc69859632a14a562983f5be3dcec973df02')
+source=("${_pkgname}::git+https://github.com/ebruck/radiotray-ng#branch=${_branch}")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -30,7 +28,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
# Build fails when GMock is found, so don't check for it, don't compile tests
- patch -uNp2 -r- -i ../remove_GMock_check.patch
+ sed -i 's:if (GMOCK_FOUND):if (GMOCK_FOUND AND ENABLE_GMOCK):' CMakeLists.txt
}
build() {
diff --git a/remove_GMock_check.patch b/remove_GMock_check.patch
deleted file mode 100644
index 0f3a1a9a43ef..000000000000
--- a/remove_GMock_check.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur ./radiotray-ng.bak/CMakeLists.txt ./radiotray-ng/CMakeLists.txt
---- ./radiotray-ng.bak/CMakeLists.txt 2017-09-23 16:01:35.457945124 -0400
-+++ ./radiotray-ng/CMakeLists.txt 2017-09-23 16:02:22.210798791 -0400
-@@ -37,7 +37,6 @@
- find_package(CURL REQUIRED)
- find_package(PkgConfig REQUIRED)
- find_package(Boost REQUIRED filesystem system log program_options thread)
--find_package(GMock)
-
- pkg_search_module(JSONCPP REQUIRED jsoncpp)
- pkg_search_module(GSTREAMER REQUIRED gstreamer-1.0)
-@@ -80,12 +79,6 @@
- set(APPINDICATOR_FOUND false)
- endif()
-
--# gmock available?
--if (GMOCK_FOUND)
-- enable_testing()
-- add_subdirectory(tests)
--endif()
--
- add_subdirectory(src/radiotray-ng)
- add_subdirectory(src/radiotray-ng/config)
- add_subdirectory(src/radiotray-ng/playlist)