summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Meyer2022-11-03 23:19:58 +0100
committerIngo Meyer2022-11-03 23:19:58 +0100
commitfb17dc2dc8cbb71ff236f5ad71130c4101280fd0 (patch)
tree1d319d02f2c3d8258ca6bfad48cefebeeb294a4d
parent0601e12ed2b034092d41ab88633866c419b1db31 (diff)
downloadaur-fb17dc2dc8cbb71ff236f5ad71130c4101280fd0.tar.gz
Add a desktop entry file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 761f4d975160..7a56ad9d40b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = radiotray-ng-mpris
pkgdesc = A wrapper script for Radiotray-NG which provides an MPRIS2 interface.
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/IngoMeyer441/radiotray-ng-mpris
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 1629c5d82868..6bfdbec68671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="radiotray-ng-mpris"
pkgver="0.1.0"
-pkgrel="1"
+pkgrel="2"
pkgdesc="A wrapper script for Radiotray-NG which provides an MPRIS2 interface."
arch=("any")
url="https://github.com/IngoMeyer441/radiotray-ng-mpris"
@@ -28,5 +28,19 @@ package() {
python setup.py install --optimize=1 \
--prefix=/usr \
--root="${pkgdir}" \
- --skip-build
+ --skip-build && \
+ cd "${pkgdir}" && \
+ mkdir -p usr/share/applications && \
+ cat <<-EOF > "usr/share/applications/radiotray-ng-mpris.desktop" || return
+ [Desktop Entry]
+ Categories=AudioVideo;Audio;Player;GTK;
+ Comment=A wrapper script for Radiotray-NG which provides an MPRIS2 interface.
+ Exec=/usr/bin/radiotray-ng-mpris
+ GenericName=Radiotray-NG MPRIS
+ Icon=/usr/share/icons/hicolor/256x256/apps/radiotray-ng-notification.png
+ Name=Radiotray-NG MPRIS
+ Terminal=false
+ Type=Application
+ Version=${pkgver}
+ EOF
}