summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-05-06 21:19:09 +0200
committerJakob Gahde2016-05-06 21:19:09 +0200
commit3e59241cf1befd3cbbe5d9de8e719c2b22766542 (patch)
tree1fb05031a41abf9d5060e8f9a48014cbb7ff7a20
parente753db812d183069e52b9e925591f278d3a35835 (diff)
downloadaur-3e59241cf1befd3cbbe5d9de8e719c2b22766542.tar.gz
radium 3.8.2-2: Fix Scheme support
In previous package releases, the packages directory was completely removed in order to save the disk space occupied by compiled object files. However this directory also contains Scheme files that are needed by Radium at runtime (e.g. for MOD file import). By specifically restoring the s7 source directory after deleting the packages directory we can retain Scheme support without wasting space.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7621d0754fcc..24c1fd39ac53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu May 5 21:19:51 UTC 2016
+# Fri May 6 19:18:34 UTC 2016
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
pkgver = 3.8.2
- pkgrel = 1
+ pkgrel = 2
url = http://users.notam02.no/~kjetism/radium/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b513dd97dfd6..6cd39c3f300d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=radium
pkgver=3.8.2
-pkgrel=1
+pkgrel=2
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
url="http://users.notam02.no/~kjetism/radium/"
@@ -46,13 +46,18 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
- # Remove objects created during packages compilation.
- rm -rf "bin/packages"
-
mkdir -p "${pkgdir}/opt/radium"
mkdir -p "${pkgdir}/usr/bin"
cp -va "bin/." "${pkgdir}/opt/radium/"
ln -s "/opt/radium/radium" "${pkgdir}/usr/bin/radium"
+
+ # Remove objects created during packages compilation.
+ rm -rf "${pkgdir}/opt/radium/packages"
+
+ # Restore s7 sources - needed to make the Scheme parts of Radium work
+ mkdir -p "${pkgdir}/opt/radium/packages"
+ tar -xvf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
+ --no-same-owner --no-same-permissions
}
# vim:set ts=4 sw=4 et: