summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2016-08-29 14:04:23 +0200
committerKenjiTakahashi2016-08-29 14:04:23 +0200
commit7553adb320a0e22fabe7073ae3b37b07c8fa4314 (patch)
tree53432badf6a0c4e48c9dc7a98657fcd6d23ec075
parentedc0887ac16c4307e21c067ced72992efec11ee5 (diff)
downloadaur-7553adb320a0e22fabe7073ae3b37b07c8fa4314.tar.gz
4.0.8-1: Bumped version
Moved to Qt5 and added compilation fixes.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f8f2b13f587..58828394cac7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jun 11 09:11:47 UTC 2016
+# Mon Aug 29 12:03:54 UTC 2016
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 3.9.3
+ pkgver = 4.0.8
pkgrel = 1
url = http://users.notam02.no/~kjetism/radium/
arch = i686
@@ -11,12 +11,15 @@ pkgbase = radium
makedepends = cmake
makedepends = gcc5
makedepends = boost
+ makedepends = llvm
+ makedepends = qt5-tools
depends = python2
depends = libxaw
depends = libsndfile
depends = libsamplerate
depends = liblrdf
- depends = qt4
+ depends = qt5-webkit
+ depends = qt5-x11extras
depends = libxkbfile
depends = glu
depends = speex
@@ -25,10 +28,10 @@ pkgbase = radium
depends = libxinerama
depends = libxcursor
options = !strip
- source = https://github.com/kmatheussen/radium/archive/3.9.3.tar.gz
+ source = https://github.com/kmatheussen/radium/archive/4.0.8.tar.gz
source = reenable-libbfd-workaround.patch
source = use-gcc5-for-pluginhost.patch
- md5sums = 93e284f36b8da0f236850a06be2b9a26
+ md5sums = 24775dcefeec066b2e6e7f105d275877
md5sums = 74ea7a54f0e358035a7f0cc7baf54b6e
md5sums = 9c19006defeef7e317ec23ed8eae1b72
diff --git a/PKGBUILD b/PKGBUILD
index 81a441997c27..e19cbb293bc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# 4. cp -va "VST3 SDK/." ~/SDKs/vstsdk2.4
pkgname=radium
-pkgver=3.9.3
+pkgver=4.0.8
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -21,7 +21,8 @@ depends=(
'libsndfile'
'libsamplerate'
'liblrdf'
- 'qt4'
+ 'qt5-webkit'
+ 'qt5-x11extras'
'libxkbfile'
'glu'
'speex'
@@ -34,18 +35,26 @@ makedepends=(
'cmake'
'gcc5'
'boost'
+ 'llvm'
+ 'qt5-tools'
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"reenable-libbfd-workaround.patch"
"use-gcc5-for-pluginhost.patch")
-md5sums=('93e284f36b8da0f236850a06be2b9a26'
+md5sums=('24775dcefeec066b2e6e7f105d275877'
'74ea7a54f0e358035a7f0cc7baf54b6e'
'9c19006defeef7e317ec23ed8eae1b72')
prepare() {
cd "${pkgname}-${pkgver}"
+ # Fix faust2 compilation on llvm 3.8.1
+ sed -i '105s/3.8.0/3.8.0 3.8.1/' "bin/packages/faust2/compiler/Makefile.unix"
+
+ # Fix Qt_instruments compilation
+ sed -i '1158s/$/ \$(API)radium_proc.h/' "Makefile.Qt"
+
# See https://github.com/kmatheussen/radium/commit/22be69fd24235cafb5878692d574d500f843c911#commitcomment-17394610
patch -Np1 < "${srcdir}/reenable-libbfd-workaround.patch"
# Some parts of JUCE that Radium uses depend on unstandardized behaviour
@@ -56,8 +65,8 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
- make packages
- BUILDTYPE=RELEASE ./build_linux.sh
+ RADIUM_QT_VERSION=5 make packages
+ RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
}
package() {