summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-11-22 09:58:53 +0100
committerJakob Gahde2016-11-22 09:58:53 +0100
commit8a30e5fc6d148b9a72cba6fb3f0a5f78436e9f14 (patch)
treeb3ebfa222c5332748fe08c57cf1cc8ff0c463d66
parent22409d78d3ba85ca347b8ed565c98026b251d5a7 (diff)
downloadaur-8a30e5fc6d148b9a72cba6fb3f0a5f78436e9f14.tar.gz
radium 4.2.9-1: New version
This release also sees a revamp of the packaging code which results in HUUUGELY improved packaging times. I also made the output a little nicer in general.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD45
2 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b366c2845bcf..7fa1ccf80163 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Nov 21 17:44:48 UTC 2016
+# Tue Nov 22 08:57:46 UTC 2016
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 4.2.8
+ pkgver = 4.2.9
pkgrel = 1
url = http://users.notam02.no/~kjetism/radium/
arch = i686
@@ -15,6 +15,7 @@ pkgbase = radium
makedepends = qt5-tools
makedepends = libxrandr
makedepends = steinberg-vst36
+ makedepends = libpthread-stubs
depends = python2
depends = libxaw
depends = libsndfile
@@ -30,12 +31,12 @@ pkgbase = radium
depends = libxinerama
depends = libxcursor
options = !strip
- source = https://github.com/kmatheussen/radium/archive/4.2.8.tar.gz
+ source = https://github.com/kmatheussen/radium/archive/4.2.9.tar.gz
source = faust-accept-clang-390.patch
source = dont-empty-qt-library-paths.patch
source = use-gcc5-for-pluginhost.patch
source = use-system-vstsdk.patch
- md5sums = 6549f8ef8ed3419afc1de9f700cea178
+ md5sums = 61e8aa38ed8f464a7d6b85bc490674f8
md5sums = 9c72bd466ead73e36b0c2d4297d76870
md5sums = 77c202bc0a36562eb7b805ad6b7a85b3
md5sums = 9c19006defeef7e317ec23ed8eae1b72
diff --git a/PKGBUILD b/PKGBUILD
index 70099f660542..85ad43d77cd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=4.2.8
+pkgver=4.2.9
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -32,6 +32,7 @@ makedepends=(
'qt5-tools'
'libxrandr'
'steinberg-vst36'
+ 'libpthread-stubs'
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
@@ -39,7 +40,7 @@ source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"dont-empty-qt-library-paths.patch"
"use-gcc5-for-pluginhost.patch"
"use-system-vstsdk.patch")
-md5sums=('6549f8ef8ed3419afc1de9f700cea178'
+md5sums=('61e8aa38ed8f464a7d6b85bc490674f8'
'9c72bd466ead73e36b0c2d4297d76870'
'77c202bc0a36562eb7b805ad6b7a85b3'
'9c19006defeef7e317ec23ed8eae1b72'
@@ -48,45 +49,53 @@ md5sums=('6549f8ef8ed3419afc1de9f700cea178'
prepare() {
cd "${pkgname}-${pkgver}"
- # Fix faust2 compilation on llvm 3.9.0
- patch -Np1 < "${srcdir}/faust-accept-clang-390.patch"
+ msg2 "Fixing faust2 compilation on llvm 3.9.0"
+ patch -Nsp1 < "${srcdir}/faust-accept-clang-390.patch"
- # Fix QT_QPA_PLATFORM_PLUGIN_PATH problem
- patch -Np1 < "${srcdir}/dont-empty-qt-library-paths.patch"
+ msg2 "Fixing QT_QPA_PLATFORM_PLUGIN_PATH problem"
+ patch -Nsp1 < "${srcdir}/dont-empty-qt-library-paths.patch"
# Some parts of JUCE that Radium uses depend on unstandardized behaviour
# specific to GCC5, so they don't compile with Arch's regular GCC6 and we
# have to switch back manually
- patch -Np1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
+ msg2 "Switching pluginhost build to GCC 5"
+ patch -Nsp1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
# Use the VST SDK from steinberg-vst36, so the user doesn't have to
# manually put it into his home directory
- patch -Np1 < "${srcdir}/use-system-vstsdk.patch"
+ msg2 "Switching to system-wide VST SDK"
+ patch -Nsp1 < "${srcdir}/use-system-vstsdk.patch"
}
build() {
cd "${pkgname}-${pkgver}"
+
+ msg2 "Building packages"
RADIUM_QT_VERSION=5 make packages
+
+ msg2 "Building Radium"
RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
}
package() {
cd "${pkgname}-${pkgver}"
- mkdir -p "${pkgdir}/opt/radium"
- mkdir -p "${pkgdir}/usr/bin"
- cp -va "bin/." "${pkgdir}/opt/radium/"
- ln -s "/opt/radium/radium" "${pkgdir}/usr/bin/radium"
+ msg2 "Installing Radium core files"
+ install -dm755 "${pkgdir}/opt/radium"
+ # Copy everything from bin except packages
+ find "bin" -mindepth 1 -maxdepth 1 -name packages -o -exec cp -a "{}" "${pkgdir}/opt/radium/" \;
- # Remove objects created during packages compilation.
- rm -rf "${pkgdir}/opt/radium/packages"
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/radium/radium_linux.bin" "${pkgdir}/usr/bin/radium"
- # Restore s7 sources - needed to make the Scheme parts of Radium work
- mkdir -p "${pkgdir}/opt/radium/packages"
- tar -xvf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
+ # Needed to make the Scheme parts of Radium work
+ msg2 "Installing s7 sources"
+ install -dm755 "${pkgdir}/opt/radium/packages"
+ tar -xf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
--no-same-owner --no-same-permissions --wildcards '*.scm'
- # Restore Faust GUI styles - Radium will complain if these are missing
+ # Radium will complain if these are missing
+ msg2 "Installing Faust GUI styles"
install -Dm644 -t "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui/Styles" \
"bin/packages/faust2/architecture/faust/gui/Styles/"*".qss"
}