summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2017-08-07 04:51:46 +0200
committerKenjiTakahashi2017-08-07 04:52:28 +0200
commitc72a25c9e238a22761e63d6268c1113f9ee1dd01 (patch)
treead24e25ff0515e3d179d587e07acda9374a273ff
parentb5ddf4f26f9ece26a87b794ee718d029ca9177b3 (diff)
downloadaur-c72a25c9e238a22761e63d6268c1113f9ee1dd01.tar.gz
4.9.14-1: Bumped version
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
-rw-r--r--dont-empty-qt-library-paths.patch42
-rwxr-xr-xradium3
-rw-r--r--use-new-cxx11-abi.patch41
-rw-r--r--use-system-libxcb.patch75
-rw-r--r--use-system-vstsdk.patch32
8 files changed, 130 insertions, 114 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 297c2b205d7f..d54e69fdbda0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 28 10:55:43 UTC 2017
+# Mon Aug 7 02:52:13 UTC 2017
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 4.8.5
+ pkgver = 4.9.14
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium/
arch = i686
@@ -11,6 +11,7 @@ pkgbase = radium
makedepends = cmake
makedepends = boost
makedepends = llvm
+ makedepends = lld
makedepends = qt5-tools
makedepends = libxrandr
makedepends = steinberg-vst36
@@ -31,14 +32,16 @@ pkgbase = radium
optdepends = calf-ladspa
optdepends = ladspa-plugins
options = !strip
- source = https://github.com/kmatheussen/radium/archive/4.8.5.tar.gz
- source = dont-empty-qt-library-paths.patch
+ source = https://github.com/kmatheussen/radium/archive/4.9.14.tar.gz
+ source = radium
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
- md5sums = 393127add9c944e98768930b0179c4fa
- md5sums = d63cea387564fa21dee775e764206a45
- md5sums = d798d5655e2899dc1b54f797d9b2bda3
- md5sums = d068d4bc99360cd4ec933c57ab9f5159
+ source = use-new-cxx11-abi.patch
+ md5sums = e12d11c59d4365af87fbaa3fbacf636c
+ md5sums = 092735a1ff69f02e41b28a0e849179f4
+ md5sums = ec8251af460ad72ebba82c718615de1b
+ md5sums = e587c15b18f761ae9af31d86162355ad
+ md5sums = ecc15fbbf114b44a657cfc3c6bf64fb8
pkgname = radium
diff --git a/.gitignore b/.gitignore
index cc659a01dad5..8c5dd95193ef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.*
+*.log
pkg/
src/
package.*
diff --git a/PKGBUILD b/PKGBUILD
index c8a85c9e79fd..70e6226ba8a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Teteros <teteros -at- opmbx -dot- org>
pkgname=radium
-pkgver=4.8.5
+pkgver=4.9.14
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -30,25 +30,29 @@ makedepends=(
'cmake'
'boost'
'llvm'
+ 'lld'
'qt5-tools'
'libxrandr'
'steinberg-vst36'
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
- "dont-empty-qt-library-paths.patch"
+ "radium"
"use-system-libxcb.patch"
- "use-system-vstsdk.patch")
-md5sums=('393127add9c944e98768930b0179c4fa'
- 'd63cea387564fa21dee775e764206a45'
- 'd798d5655e2899dc1b54f797d9b2bda3'
- 'd068d4bc99360cd4ec933c57ab9f5159')
+ "use-system-vstsdk.patch"
+ "use-new-cxx11-abi.patch"
+)
+md5sums=('e12d11c59d4365af87fbaa3fbacf636c'
+ '092735a1ff69f02e41b28a0e849179f4'
+ 'ec8251af460ad72ebba82c718615de1b'
+ 'e587c15b18f761ae9af31d86162355ad'
+ 'ecc15fbbf114b44a657cfc3c6bf64fb8')
prepare() {
cd "${pkgname}-${pkgver}"
- msg2 "Fixing QT_QPA_PLATFORM_PLUGIN_PATH problem"
- patch -Nsp1 < "${srcdir}/dont-empty-qt-library-paths.patch"
+ msg2 "Fixing faust2 LLVM ABI problem"
+ patch -Nsp1 < "${srcdir}/use-new-cxx11-abi.patch"
msg2 "Switching to system-wide libxcb"
patch -Nsp1 < "${srcdir}/use-system-libxcb.patch"
@@ -77,8 +81,8 @@ package() {
# Copy everything from bin except packages
find "bin" -mindepth 1 -maxdepth 1 -name packages -o -exec cp -a "{}" "${pkgdir}/opt/radium/" \;
- install -dm755 "${pkgdir}/usr/bin"
- ln -s "/opt/radium/radium_linux.bin" "${pkgdir}/usr/bin/radium"
+ msg2 "Installing Radium binary wrapper"
+ install -Dm755 "${srcdir}/radium" "${pkgdir}/usr/bin/radium"
# Needed to make the Scheme parts of Radium work
msg2 "Installing s7 sources"
@@ -86,6 +90,11 @@ package() {
tar -xf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
--no-same-owner --no-same-permissions --wildcards '*.scm'
+ msg2 "Installing libpd-master pure-data"
+ install -dm755 "${pkgdir}/opt/radium/packages/libpd-master/"
+ cp -a "bin/packages/libpd-master/pure-data/" \
+ "${pkgdir}/opt/radium/packages/libpd-master/"
+
# Radium will complain if these are missing
msg2 "Installing Faust GUI styles"
install -Dm644 -t "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui/Styles" \
diff --git a/dont-empty-qt-library-paths.patch b/dont-empty-qt-library-paths.patch
deleted file mode 100644
index f776e64fb500..000000000000
--- a/dont-empty-qt-library-paths.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -aur --no-dereference package.pristine/Qt/Qt_Error.cpp package.new/Qt/Qt_Error.cpp
---- package.pristine/Qt/Qt_Error.cpp 2017-04-08 14:45:26.000000000 +0200
-+++ package.new/Qt/Qt_Error.cpp 2017-04-11 19:26:40.613065282 +0200
-@@ -77,9 +77,9 @@
- if(getenv("QT_QPA_PLATFORM_PLUGIN_PATH")==NULL){
- faulty_installation = true;
- }else
-- QCoreApplication::setLibraryPaths(QStringList());
-+ //QCoreApplication::setLibraryPaths(QStringList());
- #else
-- QCoreApplication::setLibraryPaths(QStringList());
-+ //QCoreApplication::setLibraryPaths(QStringList());
- #endif
-
- QApplication app(argc,argv);
-diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
---- package.pristine/Qt/Qt_Main.cpp 2017-04-08 14:45:26.000000000 +0200
-+++ package.new/Qt/Qt_Main.cpp 2017-04-11 19:25:31.886938780 +0200
-@@ -2623,7 +2623,7 @@
- qInstallMsgHandler(myMessageOutput);
- #endif
-
-- QCoreApplication::setLibraryPaths(QStringList());
-+ //QCoreApplication::setLibraryPaths(QStringList());
-
- QCoreApplication::setAttribute(Qt::AA_X11InitThreads);
-
-diff -aur --no-dereference package.pristine/crashreporter/crashreporter.cpp package.new/crashreporter/crashreporter.cpp
---- package.pristine/crashreporter/crashreporter.cpp 2017-04-08 14:45:26.000000000 +0200
-+++ package.new/crashreporter/crashreporter.cpp 2017-04-11 19:27:08.169515448 +0200
-@@ -407,9 +407,9 @@
- if(getenv("QT_QPA_PLATFORM_PLUGIN_PATH")==NULL){
- faulty_installation = true;
- }else
-- QCoreApplication::setLibraryPaths(QStringList());
-+ //QCoreApplication::setLibraryPaths(QStringList());
- #else
-- QCoreApplication::setLibraryPaths(QStringList());
-+ //QCoreApplication::setLibraryPaths(QStringList());
- #endif
-
- QApplication app(argc,argv);
diff --git a/radium b/radium
new file mode 100755
index 000000000000..2c21a2307ff4
--- /dev/null
+++ b/radium
@@ -0,0 +1,3 @@
+#!/usr/bin/env bash
+
+QT_QPA_PLATFORM_PLUGIN_PATH=`qmake-qt5 -query QT_INSTALL_PLUGINS` /opt/radium/radium_linux.bin "$@"
diff --git a/use-new-cxx11-abi.patch b/use-new-cxx11-abi.patch
new file mode 100644
index 000000000000..6f5a991647f7
--- /dev/null
+++ b/use-new-cxx11-abi.patch
@@ -0,0 +1,41 @@
+diff -aur --no-dereference radium.pristine/bin/packages/build.sh radium.new/bin/packages/build.sh
+--- radium.pristine/bin/packages/build.sh 2017-08-02 01:59:17.650319582 +0100
++++ radium.new/bin/packages/build.sh 2017-08-02 02:01:25.370318484 +0100
+@@ -195,9 +195,9 @@
+ # Build faust last since we reset the build flags.
+
+ # faust, debug
+-export CFLAGS="-mtune=generic -msse2 -mfpmath=sse -O0 -fsanitize=address -g -Wno-misleading-indentation -fPIC -D_GLIBCXX_USE_CXX11_ABI=0 -fno-strict-aliasing"
+-export CPPFLAGS="-mtune=generic -msse2 -mfpmath=sse -O0 -fsanitize=address -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=0 -fno-strict-aliasing"
+-export CXXFLAGS="-mtune=generic -msse2 -mfpmath=sse -O0 -fsanitize=address -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=0 -fno-strict-aliasing"
++export CFLAGS="-mtune=generic -msse2 -mfpmath=sse -O0 -fsanitize=address -g -Wno-misleading-indentation -fPIC -D_GLIBCXX_USE_CXX11_ABI=1 -fno-strict-aliasing"
++export CPPFLAGS="-mtune=generic -msse2 -mfpmath=sse -O0 -fsanitize=address -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=1 -fno-strict-aliasing"
++export CXXFLAGS="-mtune=generic -msse2 -mfpmath=sse -O0 -fsanitize=address -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=1 -fno-strict-aliasing"
+ export LDFLAGS="-fsanitize=address"
+ cd faust2
+ make -j `nproc`
+@@ -206,9 +206,9 @@
+ cd ..
+
+ #faust, release
+-export CFLAGS="-mtune=generic -msse2 -mfpmath=sse -O2 -g -Wno-misleading-indentation -fPIC -D_GLIBCXX_USE_CXX11_ABI=0 -fno-strict-aliasing"
+-export CPPFLAGS="-mtune=generic -msse2 -mfpmath=sse -O2 -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=0 -fno-strict-aliasing"
+-export CXXFLAGS="-mtune=generic -msse2 -mfpmath=sse -O2 -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=0 -fno-strict-aliasing"
++export CFLAGS="-mtune=generic -msse2 -mfpmath=sse -O2 -g -Wno-misleading-indentation -fPIC -D_GLIBCXX_USE_CXX11_ABI=1 -fno-strict-aliasing"
++export CPPFLAGS="-mtune=generic -msse2 -mfpmath=sse -O2 -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=1 -fno-strict-aliasing"
++export CXXFLAGS="-mtune=generic -msse2 -mfpmath=sse -O2 -g -fPIC -D_GLIBCXX_USE_CXX11_ABI=1 -fno-strict-aliasing"
+ export LDFLAGS=""
+ cd faust2
+ make -j `nproc`
+diff -aur --no-dereference radium.pristine/Makefile.Qt radium.new/Makefile.Qt
+--- radium.pristine/Makefile.Qt 2017-08-02 01:59:17.600319582 +0100
++++ radium.new/Makefile.Qt 2017-08-02 02:00:50.420318784 +0100
+@@ -1780,7 +1780,7 @@
+ FAUST_OPTS = $(QTOPT) $(CPUOPT) -Ibin/packages/faust2/architecture $(WNO_SUGGEST_OVERRIDE) -Wno-overloaded-virtual
+
+ ifeq ($(GCC_MAJOR),7)
+- FAUST_OPTS += -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sanitize=signed-integer-overflow
++ FAUST_OPTS += -D_GLIBCXX_USE_CXX11_ABI=1 -fno-sanitize=signed-integer-overflow
+ endif
+
+ Faust_plugins.o: audio/Faust_plugins.cpp audio/Faust_factory_factory.cpp $(FAUST_DEPENDENCIES)
diff --git a/use-system-libxcb.patch b/use-system-libxcb.patch
index 422f823a0e13..febf5a68ff02 100644
--- a/use-system-libxcb.patch
+++ b/use-system-libxcb.patch
@@ -1,7 +1,7 @@
-diff -aur --no-dereference package.pristine/bin/packages/build.sh package.new/bin/packages/build.sh
---- package.pristine/bin/packages/build.sh 2017-03-26 19:27:43.000000000 +0000
-+++ package.new/bin/packages/build.sh 2017-03-30 05:14:35.867793829 +0000
-@@ -189,27 +189,27 @@
+diff -Naur package.pristine/bin/packages/build.sh package.new/bin/packages/build.sh
+--- package.pristine/bin/packages/build.sh 2017-07-27 22:03:27.000000000 +0200
++++ package.new/bin/packages/build.sh 2017-07-29 01:42:41.079439969 +0200
+@@ -168,28 +168,28 @@
cd ../
fi
@@ -12,7 +12,7 @@ diff -aur --no-dereference package.pristine/bin/packages/build.sh package.new/bi
- tar xvjf xcb-proto-1.12.tar.bz2
- cd xcb-proto-1.12/
- mkdir install
-- ./configure --prefix=`pwd`/install
+- ./configure --prefix=`pwd`/install PYTHON=`which python2`
- make
- make install
- cd ..
@@ -20,53 +20,54 @@ diff -aur --no-dereference package.pristine/bin/packages/build.sh package.new/bi
- rm -fr libxcb-1.12
- tar xvjf libxcb-1.12.tar.bz2
- cd libxcb-1.12
+- patch -p1 <../libxcb-1.12.patch
- export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.12/install/lib/pkgconfig:$PKG_CONFIG_PATH
-- ./configure
-- make
+- CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" ./configure PYTHON=`which python2`
+- CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" make
- cd ..
-
-fi
-+#if [[ $RADIUM_QT_VERSION == 5 ]]
-+#then
-+#
-+# rm -fr xcb-proto-1.12/
-+# tar xvjf xcb-proto-1.12.tar.bz2
-+# cd xcb-proto-1.12/
-+# mkdir install
-+# ./configure --prefix=`pwd`/install
-+# make
-+# make install
-+# cd ..
-+#
-+# rm -fr libxcb-1.12
-+# tar xvjf libxcb-1.12.tar.bz2
-+# cd libxcb-1.12
-+# export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.12/install/lib/pkgconfig:$PKG_CONFIG_PATH
-+# ./configure
-+# make
-+# cd ..
-+#
-+#fi
-
++# if [[ $RADIUM_QT_VERSION == 5 ]]
++# then
++#
++# rm -fr xcb-proto-1.12/
++# tar xvjf xcb-proto-1.12.tar.bz2
++# cd xcb-proto-1.12/
++# mkdir install
++# ./configure --prefix=`pwd`/install PYTHON=`which python2`
++# make
++# make install
++# cd ..
++#
++# rm -fr libxcb-1.12
++# tar xvjf libxcb-1.12.tar.bz2
++# cd libxcb-1.12
++# patch -p1 <../libxcb-1.12.patch
++# export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.12/install/lib/pkgconfig:$PKG_CONFIG_PATH
++# CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" ./configure PYTHON=`which python2`
++# CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" make
++# cd ..
++#
++# fi
- touch deletemetorebuild
-diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
---- package.pristine/Qt/Qt_Main.cpp 2017-03-26 19:27:43.000000000 +0000
-+++ package.new/Qt/Qt_Main.cpp 2017-03-30 05:12:36.587795134 +0000
-@@ -2523,6 +2523,7 @@
+ # Build faust last since we reset the build flags.
+diff -Naur package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
+--- package.pristine/Qt/Qt_Main.cpp 2017-07-27 22:03:27.000000000 +0200
++++ package.new/Qt/Qt_Main.cpp 2017-07-29 01:41:16.904955284 +0200
+@@ -3039,6 +3039,7 @@
+
#endif // !defined(RELEASE)
+/*
#if defined(FOR_LINUX)
{
QString name(dlpi_name);
-@@ -2534,7 +2535,7 @@
+@@ -3050,6 +3051,7 @@
}
}
#endif
--
+*/
+
- if (is_main_root)
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index 35bbb094c339..65683899f4ce 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -1,18 +1,6 @@
-diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
---- package.pristine/Makefile.Qt 2017-04-08 14:45:26.000000000 +0200
-+++ package.new/Makefile.Qt 2017-04-11 19:54:05.803545494 +0200
-@@ -210,7 +210,7 @@
-
- FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
-
--COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I ~/SDKs/VST3\ SDK -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
-
- ifeq ($(RADIUM_QT_VERSION),5)
- COMMONOPT += -DUSE_QT5
diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/check_dependencies.sh
---- package.pristine/check_dependencies.sh 2017-04-08 14:45:26.000000000 +0200
-+++ package.new/check_dependencies.sh 2017-04-11 19:53:20.887228014 +0200
+--- package.pristine/check_dependencies.sh 2017-08-06 00:40:00.000000000 +0200
++++ package.new/check_dependencies.sh 2017-08-06 01:57:08.330732447 +0200
@@ -137,8 +137,8 @@
exit 5
fi
@@ -24,9 +12,21 @@ diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/ch
echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html'
exit 5
fi
+diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
+--- package.pristine/Makefile.Qt 2017-08-06 00:40:00.000000000 +0200
++++ package.new/Makefile.Qt 2017-08-06 01:58:12.061943151 +0200
+@@ -226,7 +226,7 @@
+
+ FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
+
+-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I ~/SDKs/VST3\ SDK -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas -fno-strict-aliasing
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas -fno-strict-aliasing
+ #-Wstrict-overflow=4 -Wsuggest-attribute=format -Wstringop-overflow=4
+ #-Wsuggest-final-types -Wsuggest-final-methods
+
diff -aur --no-dereference package.pristine/pluginhost/Builds/Linux/Makefile package.new/pluginhost/Builds/Linux/Makefile
---- package.pristine/pluginhost/Builds/Linux/Makefile 2017-04-08 14:45:26.000000000 +0200
-+++ package.new/pluginhost/Builds/Linux/Makefile 2017-04-11 19:52:24.024336863 +0200
+--- package.pristine/pluginhost/Builds/Linux/Makefile 2017-08-06 00:40:00.000000000 +0200
++++ package.new/pluginhost/Builds/Linux/Makefile 2017-08-06 03:30:46.394038149 +0200
@@ -18,7 +18,7 @@
TARGET_ARCH := -march=native
endif