summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-11-22 19:32:12 +0100
committerJakob Gahde2016-11-22 19:32:12 +0100
commitd313326476ae7d8d0344dd0ea93639a4201510d6 (patch)
treee0a16cb56f9dd23077712f1c8b234550ace4dbf7
parent8a30e5fc6d148b9a72cba6fb3f0a5f78436e9f14 (diff)
downloadaur-d313326476ae7d8d0344dd0ea93639a4201510d6.tar.gz
radium 4.2.9-2: Don't use GCC 5 anymore, it's no longer needed
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--fix-misleading-indentation.patch12
-rw-r--r--use-gcc5-for-pluginhost.patch36
4 files changed, 21 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fa1ccf80163..fa92dd8cf6fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Nov 22 08:57:46 UTC 2016
+# Tue Nov 22 18:29:28 UTC 2016
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
pkgver = 4.2.9
- pkgrel = 1
+ pkgrel = 2
url = http://users.notam02.no/~kjetism/radium/
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
- makedepends = gcc5
makedepends = boost
makedepends = llvm
makedepends = qt5-tools
@@ -34,12 +33,12 @@ pkgbase = radium
source = https://github.com/kmatheussen/radium/archive/4.2.9.tar.gz
source = faust-accept-clang-390.patch
source = dont-empty-qt-library-paths.patch
- source = use-gcc5-for-pluginhost.patch
+ source = fix-misleading-indentation.patch
source = use-system-vstsdk.patch
md5sums = 61e8aa38ed8f464a7d6b85bc490674f8
md5sums = 9c72bd466ead73e36b0c2d4297d76870
md5sums = 77c202bc0a36562eb7b805ad6b7a85b3
- md5sums = 9c19006defeef7e317ec23ed8eae1b72
+ md5sums = 1ca36c75ce4b3fed28c22753b8dc045a
md5sums = 661c15bc037131c1ad8f8f11d3bc957f
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index 85ad43d77cd7..7156b4d42787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=radium
pkgver=4.2.9
-pkgrel=1
+pkgrel=2
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
url="http://users.notam02.no/~kjetism/radium/"
@@ -26,7 +26,6 @@ depends=(
)
makedepends=(
'cmake'
- 'gcc5'
'boost'
'llvm'
'qt5-tools'
@@ -38,12 +37,12 @@ options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"faust-accept-clang-390.patch"
"dont-empty-qt-library-paths.patch"
- "use-gcc5-for-pluginhost.patch"
+ "fix-misleading-indentation.patch"
"use-system-vstsdk.patch")
md5sums=('61e8aa38ed8f464a7d6b85bc490674f8'
'9c72bd466ead73e36b0c2d4297d76870'
'77c202bc0a36562eb7b805ad6b7a85b3'
- '9c19006defeef7e317ec23ed8eae1b72'
+ '1ca36c75ce4b3fed28c22753b8dc045a'
'661c15bc037131c1ad8f8f11d3bc957f')
prepare() {
@@ -55,11 +54,8 @@ prepare() {
msg2 "Fixing QT_QPA_PLATFORM_PLUGIN_PATH problem"
patch -Nsp1 < "${srcdir}/dont-empty-qt-library-paths.patch"
- # Some parts of JUCE that Radium uses depend on unstandardized behaviour
- # specific to GCC5, so they don't compile with Arch's regular GCC6 and we
- # have to switch back manually
- msg2 "Switching pluginhost build to GCC 5"
- patch -Nsp1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
+ msg2 "Fixing misleading indentation"
+ patch -Nsp1 < "${srcdir}/fix-misleading-indentation.patch"
# Use the VST SDK from steinberg-vst36, so the user doesn't have to
# manually put it into his home directory
diff --git a/fix-misleading-indentation.patch b/fix-misleading-indentation.patch
new file mode 100644
index 000000000000..32ba07e5606e
--- /dev/null
+++ b/fix-misleading-indentation.patch
@@ -0,0 +1,12 @@
+diff -aur --no-dereference package.pristine/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h package.new/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h
+--- package.pristine/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h 2016-11-22 17:36:12.490115783 +0100
++++ package.new/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h 2016-11-22 17:38:02.635866089 +0100
+@@ -130,7 +130,7 @@
+ if (skew != static_cast<ValueType> (1) && proportion > ValueType())
+ proportion = std::exp (std::log (proportion) / skew);
+
+- return start + (end - start) * proportion;
++ return start + (end - start) * proportion;
+ }
+
+ ValueType distanceFromMiddle = static_cast<ValueType> (2) * proportion - static_cast<ValueType> (1);
diff --git a/use-gcc5-for-pluginhost.patch b/use-gcc5-for-pluginhost.patch
deleted file mode 100644
index 3a46aea46e59..000000000000
--- a/use-gcc5-for-pluginhost.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -aur package.pristine/Makefile.Qt package.new/Makefile.Qt
---- package.pristine/Makefile.Qt 2016-06-06 16:51:53.304728252 +0200
-+++ package.new/Makefile.Qt 2016-06-06 16:56:08.792762710 +0200
-@@ -65,6 +65,7 @@
- PKG ?= pkg-config
-
- CCC ?= g++
-+PLUGINHOST_CCC ?= g++-5
- CC ?= gcc
- GCC ?= $(CC)
- GPLUSPLUS ?= $(CCC)
-@@ -407,7 +408,7 @@
- # -lasound
-
- # Adding "TARGET_ARCH=-g" to prevent juce from compiling with -march=native
--PLUGINHOSTOPTS = CXX="$(CCC) -DDEBUG_ALLOWED -DJUCE_ALSA_MIDI_INPUT_NAME=\\\"Radium\\\" -DJUCE_ALSA_MIDI_OUTPUT_NAME=\\\"Radium\\\"" TARGET_ARCH=-g
-+PLUGINHOSTOPTS = CXX="$(PLUGINHOST_CCC) -DDEBUG_ALLOWED -DJUCE_ALSA_MIDI_INPUT_NAME=\\\"Radium\\\" -DJUCE_ALSA_MIDI_OUTPUT_NAME=\\\"Radium\\\"" TARGET_ARCH=-g
-
- pluginhost/Builds/Linux/build/libMyPluginHost.a: audio/Juce_plugins.cpp midi/midi_juce.cpp flagopts.opt pluginhost/MyPluginHost.jucer $(API)/radium_proc.h
- # dryrun
-diff -aur package.pristine/build_linux_common.sh package.new/build_linux_common.sh
---- package.pristine/build_linux_common.sh 2016-06-06 16:51:53.384727636 +0200
-+++ package.new/build_linux_common.sh 2016-06-06 16:55:09.099888420 +0200
-@@ -29,6 +29,7 @@
-
- #export CCC="clang++ -mfpmath=sse -msse2"
- export CCC="g++ -mfpmath=sse -msse2"
-+export PLUGINHOST_CCC="g++-5 -mfpmath=sse -msse2"
- export CC="gcc -mfpmath=sse -msse2"
- #export CC="clang -Wno-gnu-designator -mfpmath=sse -msse2 -Wenum-conversion "
- export GCC="gcc -mfpmath=sse -msse2"
-@@ -98,3 +99,4 @@
- cp -p *.o linux_objs/ 2>/dev/null | true
-
-
-+