summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-10-30 00:28:10 +0200
committerJakob Gahde2016-10-30 00:28:10 +0200
commitdbd7b0fc5338da6fab2719424ee0329ab43393ca (patch)
tree7bdaef918d02051864c583c58ce07ae271f37168
parent07350c24f72b5fe9a448ee0cdb4a3d01e89a97f2 (diff)
downloadaur-dbd7b0fc5338da6fab2719424ee0329ab43393ca.tar.gz
Use system-wide VST SDK from steinberg-vst36
Also: Fix loading of xcb platform plugin (again) Also: Allow the Faust part to be built with LLVM 3.9.0 Also: Include Faust GUI styles in the package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
-rw-r--r--dont-empty-qt-library-paths.patch36
-rw-r--r--faust-accept-clang-390.patch12
-rw-r--r--use-system-vstsdk.patch38
5 files changed, 117 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 423646a5568c..b949588abd0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 5 00:30:34 UTC 2016
+# Sat Oct 29 22:27:18 UTC 2016
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
pkgver = 4.1.6
- pkgrel = 1
+ pkgrel = 2
url = http://users.notam02.no/~kjetism/radium/
arch = i686
arch = x86_64
@@ -13,6 +13,8 @@ pkgbase = radium
makedepends = boost
makedepends = llvm
makedepends = qt5-tools
+ makedepends = libxrandr
+ makedepends = steinberg-vst36
depends = python2
depends = libxaw
depends = libsndfile
@@ -29,11 +31,17 @@ pkgbase = radium
depends = libxcursor
options = !strip
source = https://github.com/kmatheussen/radium/archive/4.1.6.tar.gz
+ source = faust-accept-clang-390.patch
+ source = dont-empty-qt-library-paths.patch
source = reenable-libbfd-workaround.patch
source = use-gcc5-for-pluginhost.patch
+ source = use-system-vstsdk.patch
md5sums = 538cb0ffab64719bbda03b1c434448e3
+ md5sums = 9c72bd466ead73e36b0c2d4297d76870
+ md5sums = 77c202bc0a36562eb7b805ad6b7a85b3
md5sums = 74ea7a54f0e358035a7f0cc7baf54b6e
md5sums = 9c19006defeef7e317ec23ed8eae1b72
+ md5sums = a634357218872c0502202d3c738b5a9d
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index bb298033dc2d..23f29f9dde75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,9 @@
# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
-# NOTICE: This needs Steinberg VST Audio Plug-Ins SDK in ~/SDKs to work.
-# It can obtained like this:
-# 1. curl -LO http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip
-# 2. unzip vstsdk360_22_11_2013_build_100.zip
-# 3. mkdir -p ~/SDKs/vstsdk2.4
-# 4. cp -va "VST3 SDK/." ~/SDKs/vstsdk2.4
-
pkgname=radium
pkgver=4.1.6
-pkgrel=1
+pkgrel=2
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
url="http://users.notam02.no/~kjetism/radium/"
@@ -37,23 +30,31 @@ makedepends=(
'boost'
'llvm'
'qt5-tools'
+ 'libxrandr'
+ 'steinberg-vst36'
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
+ "faust-accept-clang-390.patch"
+ "dont-empty-qt-library-paths.patch"
"reenable-libbfd-workaround.patch"
- "use-gcc5-for-pluginhost.patch")
+ "use-gcc5-for-pluginhost.patch"
+ "use-system-vstsdk.patch")
md5sums=('538cb0ffab64719bbda03b1c434448e3'
+ '9c72bd466ead73e36b0c2d4297d76870'
+ '77c202bc0a36562eb7b805ad6b7a85b3'
'74ea7a54f0e358035a7f0cc7baf54b6e'
- '9c19006defeef7e317ec23ed8eae1b72')
+ '9c19006defeef7e317ec23ed8eae1b72'
+ 'a634357218872c0502202d3c738b5a9d')
prepare() {
cd "${pkgname}-${pkgver}"
- # Fix faust2 compilation on llvm 3.8.1
- sed -i '105s/3.8.0/3.8.0 3.8.1/' "bin/packages/faust2/compiler/Makefile.unix"
+ # Fix faust2 compilation on llvm 3.9.0
+ patch -Np1 < "${srcdir}/faust-accept-clang-390.patch"
# Fix QT_QPA_PLATFORM_PLUGIN_PATH problem
- sed -i '2224d' "Qt/Qt_Main.cpp"
+ patch -Np1 < "${srcdir}/dont-empty-qt-library-paths.patch"
# See https://github.com/kmatheussen/radium/commit/22be69fd24235cafb5878692d574d500f843c911#commitcomment-17394610
patch -Np1 < "${srcdir}/reenable-libbfd-workaround.patch"
@@ -61,6 +62,9 @@ prepare() {
# specific to GCC5, so they don't compile with Arch's regular GCC6 and we
# have to switch back manually
patch -Np1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
+ # Use the VST SDK from steinberg-vst36, so the user doesn't have to
+ # manually put it into his home directory
+ patch -Np1 < "${srcdir}/use-system-vstsdk.patch"
}
build() {
@@ -84,6 +88,10 @@ package() {
mkdir -p "${pkgdir}/opt/radium/packages"
tar -xvf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
--no-same-owner --no-same-permissions --wildcards '*.scm'
+
+ # Restore Faust GUI styles - Radium will complain if these are missing
+ install -Dm644 -t "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui/Styles" \
+ "bin/packages/faust2/architecture/faust/gui/Styles/"*".qss"
}
# vim:set ts=4 sw=4 et:
diff --git a/dont-empty-qt-library-paths.patch b/dont-empty-qt-library-paths.patch
new file mode 100644
index 000000000000..5a8e4ca9fb83
--- /dev/null
+++ b/dont-empty-qt-library-paths.patch
@@ -0,0 +1,36 @@
+diff -aur --no-dereference package.pristine/Qt/Qt_Error.cpp package.new/Qt/Qt_Error.cpp
+--- package.pristine/Qt/Qt_Error.cpp 2016-10-29 19:20:29.405129735 +0200
++++ package.new/Qt/Qt_Error.cpp 2016-10-29 19:21:28.281368400 +0200
+@@ -63,7 +63,7 @@
+ QSplashScreen *g_splashscreen = NULL; // referenced by helpers.h
+
+ int main(int argc, char **argv){
+- QCoreApplication::setLibraryPaths(QStringList());
++ //QCoreApplication::setLibraryPaths(QStringList());
+
+ QApplication app(argc,argv);
+ int ret = show_message(argv[1]);
+diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
+--- package.pristine/Qt/Qt_Main.cpp 2016-10-29 19:20:29.405129735 +0200
++++ package.new/Qt/Qt_Main.cpp 2016-10-29 19:21:07.024856269 +0200
+@@ -2274,7 +2274,7 @@
+ qInstallMsgHandler(myMessageOutput);
+ #endif
+
+- QCoreApplication::setLibraryPaths(QStringList());
++ //QCoreApplication::setLibraryPaths(QStringList());
+
+ QCoreApplication::setAttribute(Qt::AA_X11InitThreads);
+
+diff -aur --no-dereference package.pristine/crashreporter/crashreporter.cpp package.new/crashreporter/crashreporter.cpp
+--- package.pristine/crashreporter/crashreporter.cpp 2016-10-29 19:20:29.541795408 +0200
++++ package.new/crashreporter/crashreporter.cpp 2016-10-29 19:20:46.425006019 +0200
+@@ -395,7 +395,7 @@
+
+ int main(int argc, char **argv){
+
+- QCoreApplication::setLibraryPaths(QStringList());
++ //QCoreApplication::setLibraryPaths(QStringList());
+
+ QApplication app(argc,argv);
+
diff --git a/faust-accept-clang-390.patch b/faust-accept-clang-390.patch
new file mode 100644
index 000000000000..568fec8cf42a
--- /dev/null
+++ b/faust-accept-clang-390.patch
@@ -0,0 +1,12 @@
+diff -aur --no-dereference package.pristine/bin/packages/faust2/compiler/Makefile.unix package.new/bin/packages/faust2/compiler/Makefile.unix
+--- package.pristine/bin/packages/faust2/compiler/Makefile.unix 2016-10-29 17:56:44.082520406 +0200
++++ package.new/bin/packages/faust2/compiler/Makefile.unix 2016-10-29 17:56:54.242445169 +0200
+@@ -102,7 +102,7 @@
+ CLANGLIBS=$(CLANGLIBSLIST)
+ CXXFLAGS += -std=gnu++11
+
+-else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0))
++else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0 3.9.0))
+ LLVM_VERSION = LLVM_38
+ CLANGLIBS=$(CLANGLIBSLIST)
+ CXXFLAGS += -std=gnu++11
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
new file mode 100644
index 000000000000..e8a496d802ca
--- /dev/null
+++ b/use-system-vstsdk.patch
@@ -0,0 +1,38 @@
+diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
+--- package.pristine/Makefile.Qt 2016-10-29 12:36:00.479600104 +0200
++++ package.new/Makefile.Qt 2016-10-29 12:38:36.228464209 +0200
+@@ -190,7 +190,7 @@
+
+ FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
+
+-COMMONOPT = -c `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I${HOME}/SDKs/vstsdk2.4 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
++COMMONOPT = -c `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
+
+ ifeq ($(RADIUM_QT_VERSION),5)
+ COMMONOPT += -DUSE_QT5
+diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/check_dependencies.sh
+--- package.pristine/check_dependencies.sh 2016-10-29 12:36:00.136269274 +0200
++++ package.new/check_dependencies.sh 2016-10-29 12:36:53.429214014 +0200
+@@ -127,8 +127,8 @@
+ exit 5
+ fi
+
+-if [ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h ] ; then
+- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h")'
++if [ ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h ] ; then
++ echo 'Steinberg VST headers not found. (Missing "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h")'
+ echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html'
+ exit 5
+ fi
+diff -aur --no-dereference package.pristine/pluginhost/Builds/Linux/Makefile package.new/pluginhost/Builds/Linux/Makefile
+--- package.pristine/pluginhost/Builds/Linux/Makefile 2016-10-29 12:36:00.166269054 +0200
++++ package.new/pluginhost/Builds/Linux/Makefile 2016-10-29 12:38:05.555354633 +0200
+@@ -38,7 +38,7 @@
+ TARGET_ARCH := -march=native
+ endif
+
+- CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4
++ CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I /usr/include/vst36
+ CFLAGS += $(CPPFLAGS) $(TARGET_ARCH) -g -ggdb -O3 -I../../../Qt `cat ../../../flagopts.opt`
+ CXXFLAGS += $(CFLAGS) -std=c++11
+ LDFLAGS += $(TARGET_ARCH) -L$(BINDIR) -L$(LIBDIR) -L/usr/X11R6/lib/ -lX11 -lXext -lXinerama -lasound -ldl -lfreetype -lpthread -lrt